Problem with 3rd party clone

Hi, I am trying to get what I think is a dev kit version of Arduboy to work. Bought it from Australian Jaycar company:
(the big square chip is in the middle of the back panel).
When we first assembled and turned on, it worked ok with Castle Boy already loaded (but no sounds)- do these things have sounds??
I followed all the instructions on loading Arduino software, libraries etc etc, and successfully uploaded the Hello World example. Then tried to upload a game (JetPac), and since then the screen is blank, and it does nothing. Also the port wasn’t recognising at that point either. Have fiddled around with what I think is a reset button (top LHS beside the screen). That can get Arduino to recognise the port, and have tried uploading various things including going back to the safe examples, but nothing is working. I found this article, but the photos don’t load properly, so I can’t see what I’m meant to be shorting. Have tried loading this article in chrome, safari etc but the pictures aren’t there. This has been a really rubbish introduction to this whole platform for my young son and I… :frowning:

A post was merged into an existing topic: New maycar Arduboy- think this is Dev kit but struggling