Problems compiling 1944 - Return to Midway (Horiz)

i downloded the from GitHub and now im trying to upload to my arduboy, but the error “src/Utils/Arduboy2EXT.h: no such file or directory” pops up, what do i do?

Sorry to hear that but I have checked and the file is in the GitHub repository.

A couple of questions:

  • Is there a file named src/Utils/Arduboy2EXT.h in your directory?

  • Does the error message have capital EXT as you have shown above or ‘Ext’?

  • Are you using the Arduino IDE? If so, when you opened the .ino file did it give some message about the INO file not being contained in a directory with the same name as the folder? If so, what option did you choose?

1 Like
  1. I don’t know where to check that, I’m a complete noob at this sorry lol

  2. It was in caps

  3. I didn’t get a message at all, just until I tried to upload it to my Arduboy

Thank you for responding

OK

  1. When you downloaded the zip file, you must have expanded it into a directory. In that directory, there should be a src subdirectory. Drill down to the Utils directory and look for two files with names Arduboy2Ext.h and Arduboy2Ext.cpp. Are they there?

  2. it was in caps? Are you using Linux? My code must specify it in caps and that is normally not a problem in Windows. Linux is fussier.

  3. are you using the Arduino IDE?

I’m using Mac and yes I’m using Arduino IDE

Yes they are there, what do I do with them?

OK, I have done the same on my Macintosh now that I am home.

The simplest think to do is delete everything you have for the game and unzip it again.

When you unzip it, you will see that the contents are unzipped into a directory called Nineteen44-master. Before opening it within the Arduino IDE, rename the folder to simply Nineteen44.

You should now be able to open it properly and upload it to your machine.

I actually do not use the Arduino IDE as it cannot handle subfolders properly and use Microsoft VSCode.


For this game and others you might download …

If you see this message pop up, always click cancel and get out of the IDE. Rename the containing folder so it matches the .ino filename exactly. Then you can reopen it. This is a little (stupid) quirk of the Arduino IDE.

1 Like

You are awesome thank you

1 Like

I am going through and fixing this (and other games) in GitHub so there is an extra folder in the hierarchy with the correct name.

If you are planning on doing any coding, check out VSCode!

2 Likes

The whole Arduino ecosystem has many stupid little quirks. :P

Great game, lot’s of fun. Graphics are amazing.
Great memories -

Thanks!!

1 Like

Graphics were done by @vampirics … they absolutely make the game!

1 Like

Umm…

“Sketch uses 28806 bytes (100%) of program storage space. Maximum is 28672 bytes.
Global variables use 1613 bytes (63%) of dynamic memory, leaving 947 bytes for local variables. Maximum is 2560 bytes.” I got this message…

Looks OK to me … I have written programs that use more. Did it run?

Oops I forgot to include it said “Sketch too big”

Sorry I misread the size … its 28806! I read that as 28606.

Anyhow, what version of the Arduino library / IDE are you running?

I think 1.8.12?

OK, If you look at the file Enums.h do your settings match mine?

#define SAVE_MEMORY
#define _USE_LEDS
#define USE_ISLAND_3
#define HIGH_SCORES

If your version has no underscore in front of USE_LEDS then can you add one?

This version of code has a bunch of #defines that allow me to turn sections on and off to fit the Arduboy and the Microcard. Before Arduino 1.8.12 and on older versions of the Arduboy library, I had to turn off other features to get it to fit into the memory available.

Where exactly is Enums.h?