ProjectABE (ArduBoy Emulator) released!


(Simon) #305

Yes and I believe so.

I am actually using a Mega and have followed this table:

There is a wiring diagram (to another UNO):

I did not use the capacitor as I believe I did not need it.

Should we take this offline?


Arduino Mega as ISP
(Felipe Manga) #306

That’s for a 328 (Uno), the Arduboy is a 32U4 (Leonardo).
See the table here: https://learn.sparkfun.com/tutorials/installing-an-arduino-bootloader

Instead of pins 11, 12, 13, it’s supposed to be 16, 14, 15.


(Simon) #307

As mentioned, I am actually using the Mega pins in row 2.


(Scott R) #308

I took the liberty of making a topic


#309

I love the new 1:1, 2:2, and 4:4 skins! Thank you! Fixed aspect ratio also looks much much better!


#310

Does the RGB LED work properly on the emulator? I noticed it updates very slowly in general (once every few seconds) and sometimes gets stuck entirely until I restart the program.


(Felipe Manga) #311

It should work if you control it with the digital functions. The analogue ones require PWM, which hasn’t been implemented yet. That’s currently being tracked in this issue.


#312

Aha, thats that issue then.
I am trying to use PWM to control the LED. Guess I have to wait until my real arduboy is here then.

Not a big deal though, the LED is just a bit of eye candy either way. :+1:


(Alex) #313

I have an idea: You should be able to drag and drop a folder into an abe project and it being able to load it up instantly instead of ctrl-c ctrl-v-ing everything on to the emulator, would make it a bit easier if you prefer developing on an alternate text editor.


(Felipe Manga) #314

From what I remember, drag-and-drop for folders was a bit iffy on some browsers. Instead, you can zip your files together and drop that into the editor.


(Gavin Atkin) #315

I may have already asked this, but TEAM a.r.g.'s games I’ve tried run at about double the speed they do on the Arduboy. Is there a way to fix this? I’m using Chrome. I tried Edge, but it won’t load any of the games. I also tried the offline version with the same issue.


(Felipe Manga) #316

I just made an update after spending some time looking at the stopwatch in Ardletics and making sure it stayed in sync with an actual clock. Can you check if there’s still a speed difference? If there is, is it specific to certain games? You might need to clear the browser cache to be sure you’re looking at the latest version.


(Gavin Atkin) #317

Yes, that appears to have fixed it. Thank you, nice work :smiley:


(Alex) #318

Another thing im noticing. The graphics get really distorted because they are upscaled, is there a downsized mode where the screen isnt distorted?


(Felipe Manga) #319

Yes. Press F3 a few times (I forget exactly how many).


(Alex) #320

Its not working, I press f3 again and again on source/emulator and nothing occurs.


(Felipe Manga) #321

Hmm… if you click on the Arduboy then press F3, nothing happens?
Does the keyboard respond at all (up/down/left/right/A/B/Ctrl/Alt)?
What browser/OS are you using?


(Alex) #322

Im using the application on windows 10. The keyboard does work.


(Felipe Manga) #323

Ah, you’re using the offline version? That feature is not in the offline builds, yet.


(Alex) #324

Please add it to the offline edition.