Python Uploader and EEPROM backup and restore

I was joking about there being five. Starduino is the only one I could think of.

As you’ve evidently realised, Circuit Dude does have source code available, but it’s not under an open source licence, much like Midnight Wild. (Though I’m not sure if the source code for Circuit Dude is up to date or not, it might only contain the older levels.)

There’s a few games that don’t have any licences, but all the examples I’m aware of have source code available.

So Starduino is genuinely the only truly closed source Arduboy game that I can think of.
Everything else is at least source available as far as I’m aware.

1 Like

Yes I forgor the source for Circuit dude was available. So It can be downloaded and recompiled for Homemade arduboys.

Starduino is the only one I know of too. Luckily it works fine with SSD1309 displays too. Patching for alternate wiring isn’t a problem. But since distribution is denied. It has to be a hex patcher to apply patch.

1 Like

Great!

That would be amazing :smiley:

and to prove I’m not full of :poop:

I did the display patching a while ago but now I finished adding two channel sound support too. Guess I need to work on that hex file patcher…
I’ll add the patcher to the python utilities when ready.

2 Likes

That’s great. Thanks for taking the time to do this, much appreciated :smiley:

And there’s the patcher :smiley:

2 Likes

This is the error I get when I run the flashcart builder script

Error: CSV-file ‘/Users/om/Desktop/example-flashcartflashcart-index.csv’ not found.

Looks like there is a path separator missing?

Error: CSV-file ‘/Users/om/Desktop/example-flashcart right about here flashcart-index.csv’ not found.

4 Likes


There is a seperator though.

Try typing a / instead of a \. It doesn’t matter on Windows, but I think the difference matters on Linux.
(Also, some software will interpret \f as a character escape for the form feed character.)

2 Likes

If you’re not on Windows use a ‘/’

lol @Pharap just beat me

2 Likes

Okay, thanks, it worked :grinning:

1 Like

Now when I run it, it gives this error

Error: Title screen ‘/Users/om/Desktop/example-flashcarts/example/’ not found.

I have customized the flashcart so maybe there is a problem with the file?

if you look at that file path you’ll see that it is only a file path (ends with ‘/’ ) and does not contain a filename. you’ll need to add a filename of the title screen image to the CSV.

1 Like

So I do “example\arduboy_loader.png”?

yes,but you may want to start with ‘./’ so current directory is added by the script

1 Like

I still get the error. This is what the terminal and csv file looks like:


Did you edit the csv? if so can you edit the csv with a text editor and copy and paste the first few lines here?

1 Like

This is what it says in a text editor:

List,Title,Title screen,Hex file,Data file,Save file,Version,Developer,Info,Likes

0,Example flashcart,arduboy_loader.png,Example flashcart with a some games and categories,

1,Action Games,category-screens/Action.png,

1,Evade,Action/Evade.png,Action/Evade.hex,

2,Arcade Games,category-screens/Arcade.png,

2,

2,

3,Platformer Games,category-screens/Platformer.png,

3,CastleBoy,Platformer/CastleBoy.png,Platformer/CastleBoy.hex,

4,Puzzle Games,category-screens/Puzzle.png,

4,

4,

4,

5,Racing Games,category-screens/Racing.png,

5,

6,RPG Games,category-screens/RPG.png,

6,

7,Shooter Games,category-screens/Shooter.png,

7,

The CSV format is incorrect. items should be seperated by semicolons and not commas just like the original example.

2 Likes