Rayne the Rogue


Rayne the Rogue


As a child Rayne watched the rich from the streets of the village and burned with jealousy. After years and years of poverty an idea formed. Rayne has decided to sneak into the lairs of dragons and steel their treasures. Rayne need your help to navigate the dangerous caves and avoid the dragon’s breath to become the wealthiest person in the village, but take heed, the further Rayne gets the more treacherous it will be.


Navigate Rayne from cave to cave taking the dragon’s treasures, but beware their foul breath.




Coin with 1 notch - 1

Coin with 2 notches - 10

Bag with 1 notch - 10

Pouch with 1 notch - 20

Candelabra - 25

Chest with 1 notch - 50

Coin with 3 notches - 100

Bag with 2 notches - 100

Pouch with 2 notches - 200

Chest with 2 notches - 500

Harp - 750

Coin with 4 notches - 1000

Bag with 3 notches - 1000

Pouch with 3 notches - 2000

Chest with 3 notches - 5000

Lamp - 7500

Bag with 4 notches - 10000

Pouch with 4 notches - 20000

Diamond - 25000

Chest with 4 notches - 50000

Potion of Cold Resist - 500 - 1 point of cold resist

Potion of Acid Resist - 500 - 1 point of acid resist

Potion of Luck - 1000 - 1 point of luck

Potion of Invisibility - 250- 2 points of Invisibility

Potion of Speed Boost - 250- 2 points of Speed Boost

Large Potion of Cold Resist - 2000- 5 point of cold resist

Large Potion of Acid Resist - 2000- 5 point of cold resist

Large Potion of Luck - 4500- 5 point of cold resist

Large Potion of Invisibility - 1000- 10 point of cold resist

Large Potion of Speed Boost - 1000- 10 point of cold resist

Ring of Cold Resist - 20000 - 1 point of cold resist permanent

Ring of Acid Resist - 20000 - 1 point of acid resist permanent

Ring of Luck - 50000 - 1 point of luck permanent

Ring of Invisibility - 10000 - 2 points of Invisibility permanent

Ring of Speed Boost - 10000 - 2 points of Speed Boost permanent

Key - unlocks the door

Open Door - exit cave

Locked Door - need key to unlock

Hold up when starting the game to play on Hard Difficulty
If you die on Hard all of you items and gold will be lost
Hold up and B when starting to erase the hard save game
Hold down and B when starting to erase the normal save game
Hold A & B when starting to erase EEPROM
Uses 32 bytes of EEPROM
Uses the Shadow File System
saves game files to empty location
loads the saved game after finding it anywhere in eprom


You have based your code on a version of the Arduboy library that is still in development and hasn’t yet been released. As such, it will conflict with the version of the library, V1.1.0, that most people will have installed using the IDE Library Manager, as instructed in the Quick Start Guide.

You’ll probably get many complaints that the game doesn’t compile properly. I would suggest that you modify the game to work with the released V1.1.0 Arduboy Library, until the version under development is released.

1 Like

It might be worth posting a markdown file somewhere with a development roadmap, and what each tag or target is intended for. The flow chart @JO3RI came up with might be a nice way to publish this information.

this game doesn’t load because it is not using the proper Arduino library

I am aware, unfortunately i built the game using the Arduboy 1.2 library. I have been unable to get the 1.1 library to work since it uses quite a bit more memory than 1.2 does.

1 Like

How do i go about getting it to work on my device?

@shdwwzrd I think you just gave the impetuous to get the 1.2 out into the wild.

To use this game, you could go to https://github.com/Arduboy/Arduboy and simply clone/download the master branch as your Arduboy Library, delete the existing one in your Arduino IDE libraries folder, and install the new Arduboy Library you pulled from Github.

Then this game should work fine.

Pretty sick game can’t wait till my arduboy comes so I can play it

Okay :smiley: crosses fingers

If you would like to run multiple versions of the IDE, it is also possible.

I have a few IDE versions installed, just download the standalone versions, and then set the location of each libraries folder for each IDE (done in the IDE’s settings menu) to something unique. Then install the Arduboy Library in each, through the manager of each client if possible. I have all of my library folders in my /home/<user>/Documents/ folder like this,

  ├── Arduino/
  │   └── libraries/
  │       └── Arduboy/
  └── Arduino105/
      └── libraries/
           └── Arduboy/

Well I don’t know where I went wrong with the Guide but it works now! :smiley: and I will totally do that as well!


I can’t figure out which game is my favorite yet!!

1 Like

Sorry for the multiple posts.

So I got it loaded and it boots w/o a problem.
However after pressing play, I can’t get past the second screen…no matter how many times I press B or any other buttons…

Any luck? I haven’t tried loading the game yet myself.

It is still stuck on the “press B to start” page

Sounds like the save game function is failing, I’ll look into a way to notify the user when saving has failed and a way to disable save game functionality,

The only way i know for the save game to fail is no memory available. My code looks for space available in eeprom and then saves and loads from that location.


That is strange, I have the consumer version if that makes any difference

For now, the most painless solution (maybe not for you, but for others) is probably to include copies of the Arduboy 1.2 library files and current Arduboy Playtune library files within the sketch itself.

After copying in all the necessary files, rename them to avoid possible conflicts.
E.g. Arduboy.h to ArduboyRtR.h, etc.

Make the necessary adjustments to #include statments.
E.g. #include <Arduboy.h> to #include "ArduboyRtR.h"

Once the newer compatible Arduboy and Playtune libraries are officially released, you can switch your sketch back to using them, to automatically get any improvements or fixes that are made.


Hi, total Ardun00b here, just got my KS version yesterday and this immediately caught my attention.
I installed the 1.2 lib but it still sticks on “Press B To Start”.

I have tried out many games so far so is there some “saves” that these games have made, taking up space? I can’t find a way to free up memory on the Arduboy.

Thanks! Game looks great, can’t wait to try it

1 Like

Sorry for the multiple posts but I got it to work on my KS Arduboy. Michael was right, it was the eeprom. I held down A as I turned on the machine, the screen looked like static for a second, then the game began and worked through the menus to the game proper.

Hope this helps someone. I don’t know if my Arduboy’s eeprom was full or what but there you are.

1 Like

Thank you kind madam or sir!