[Resolved] Issues uploading with Ubuntu 18.10 and Arduino 1.8.9

#1

So I have Lubuntu on a computer and I wanted to see if I could set it up to have the arduino IDE on it. So I downloaded the latest, extracted it, and launched it by going into to the extracted folder and running the command
./arduino
and then I downloaded all of the libraries for arduboy and set the target and port to arduino leonardo and the port my arduboy was on. When I tried to upload ardubreakout (or any game) it would compile and after uploading, the screen would stay blank. Nothing would upload unless I used the reset button. (I can still upload stuff on other computers just fine via the reset button) Whenever I try to upload from the lubuntu computer, I get a lot of errors. I’ll put part of it down below. I don’t know what I did wrong. The errors are mostly the same with different pages and addresses. The verification error happens only at the end.

avrdude: Error: butterfly programmer uses avr_write_page() but does not
provide a cmd() method.
*** page 105 (addresses 0x39ea - 0x3a69) failed to write

avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: verification error, first mismatch at byte 0x0000
0xcf != 0x0c
avrdude: verification error; content mismatch
avrdude: verification error; content mismatch

Update: Uploading it with Blinky’s python tools on the same computer works fine, however when I tried to upload it the first time after the error, it said “Verify failed at address 0000. Upload unsuccessful.” despite being successful.

0 Likes

(Scott) #2

I have no problems with Ubuntu 16.04

I more or less use the following instructions to install the IDE:
http://ubuntuhandbook.org/index.php/2015/11/install-arduino-ide-1-6-6-ubuntu/

except I find the
chmod +x install.sh
command isn’t necessary (though it won’t hurt).

0 Likes

#3

Did you also try using another USB port and/or cable?

My linux experience is limited to that of the RaspberriPi but…

Gives me the impression something might be interrupting /interfering the upload process. I’ve read here that the modemmanager can cause problems. I don’t know if it’s present in lubuntu. but you could try the following commands:

$ sudo usermod -a -G dialout <yourUserName>
$ sudo apt-get --purge remove modemmanager

Edit:
(the 1st line isn’t necessary in your case since you where able to upload)

0 Likes

(Scott) #4

It’s better to just disable Modem Manager, rather than removing it entirely. For Ubuntu or other systemd distrubutions:
sudo systemctl disable ModemManager.service

However, Modem Manager will lock out the port, giving a different error message.

0 Likes

(Kevin) #5

Odd, you might try bringing up the issue on Arduino forums too and see if you can get any help there. It does seem to be something related to the communication mux for the usb, but I don’t know enough about linux to help.

0 Likes

#6

Disabling ModemManager fixed uploading from the Arduino IDE! I’m glad that y’all were able to help me. Thanks!

3 Likes