Rogue-like ascii based on Arduboy


(Simon) #221

It translated as ‘Fairlap’ and suggested you had a strange relationship with a goat. Not sure what that is about.


(Stephane C) #222

LMAO… I must be tired like hell. I was literally laughing so much I got cramps lol


#223

Hello, everyone.

To @Vampirics

This program marks the 20th in EEPROM when saving. Then, when loading the data, delete that mark. The mark indicates whether the hero is in EEPROM or in memory. If you turn off the power on other than the title screen, the mark indicates “on memory”, so you can not select “Continue game”. This is a specification that makes it impossible to rewind time because the game did not go well. After that, by putting save function, free memory has almost become 0 byte. In order to put additional data, something more innovative is necessary.

To @Pharap.

I see. this is convenient. I wish I knew this from a long time ago.


(Pharap) #224

I’m sorry, I don’t understand.
I’ll have to consult my Australian phrase book in the morning to figure out what you were actually saying.


Clever.

This is why I suggested GitHub.
I wanted to explain sooner, but I wasn’t sure how to explain it.
Version control (バージョン管理) is a powerful tool.


#225

Pharap / Fairlap in an Aussie phrase book would probably get you this:


(Pharap) #226

Fortunately there are worse things to be confused with than a horse.


(Simon) #227

The Fairlap and your goat fetish are unrelated in that sentence.


#228

Hello everyone!
Do you dive in the dungeon? When I want to divide into a dungeon for a while, I am placing an amulet around the 5th floor.:grinning:

I found a minor problem, so I will release a new version. The new version is 1.5.1.

Rogue151.zip.pdf (57.0 KB)

This version is:

  • [FIX] The probability of being awake is too high when a monster is created
  • [FIX] When continuing the game, a meaningless message is displayed
  • [SYS] The hero will get off the stairs without permission.*1

*1 It is a problem when implementing “save function”. This will cause 1 turn to pass when displaying “status screen”. Please be careful when you are about to die.

Only this?
This time, I will distribute two .hex. One is the usual font version, the other is the original font version. Please challenge the dungeon with your favorite one! :wink:


(Simon) #229

Do you think you can update the source in GitHub?


(Stephane C) #230

Is it just me or what’s on GitHub still doesn’t compile because it’s too big for the default bootloader?


(Bert Veer) #231

Not just a horse. The best racing horse to ever live. It died under mysterious conditions, quite a story. Phar Lap was also the name of a popular DOS extender.


(Pharap) #232

I’d never heard of either until now.

Horse racing isn’t really something I’m interested in, despite its prominence here.

The software company is somewhat interesting though.


#233

To @filmote.

Sorry, I commited the source now.

I can compile it on caterina bootloader. I do not know why.


(Scott R) #234

I quit horses in my teens Whittakers Ascot Gold Cup stole all my money I’m pretty sure it was fixed.

@BlueMax are you compiling with the optimised core? This could possibly be why it compiles for you and not @Vampirics.
Size differences could also be down to ide or a library revision.


(Stephane C) #235

When I tried to compile what was in your repo earlier today it gave me a message saying it’s at 101% of progmem. But maybe you updated it since, I will have to try tomorrow.


(Simon) #236

Same. It is also unclear which of the .ino files is the ‘master’.


#237

I am so sorry, @Vampirics and @filmote.
You were right.

Thank you, @Keyboard_Camper.
You are right.
I used old versions of both arduino IDE and arduboy 's library. The arduino IDE version was 1.8.1 and library was 5.1.0. really sorry…
This seems to be caused by “spritesB ::” did not work.

Well, I’m in trouble…


#238

To @Vampirics, @filmote.

I committed the modified source to GitHub. The environment is arduino IDE 1.8.8 and arduboy 2 library 5.2.0. Will it work?

However, font inversion display is no longer possible. Because of that, I got some free memory. It became more plain and more “Rogue” was added. I am an optimist.:grin:


(Josh Goebel) #239

I’m a little confused. how are you guys evening compiling this? Arduino wants a Rogue1.4/Rogue1.4.ino file but instead we have this weird Hello world file? Could we please correct that or am I just missing something?


(Pharap) #240

By renaming the file of course. (Or the directory, whichever you prefer.)