Same Error!

I’ve made a post before saying that I had an issue uploading a game to my arduboy. Someone responded telling me to download every arduboy library, which I did. My game then uploaded to my arduboy like it was supposed to. However, I decided to upload a different game today and it gave me the same error that I experienced a few days ago. The EXACT same error, despite the fact that I had downloaded every library. There’s now no library that I need to download, yet the game won’t upload to my arduboy. I even checked to make sure my libraries were still downloaded, which they were. I can’t understand what’s happening.

Where did you download the libraries from or to? You used the library manager?

What is the error that you are getting?

  • What error?
  • Which game?

When referring to the previous post you created are you referring to this?

Indeed I am

1 Like

I was getting an error that said arduboy2: no such file or directory. Someone told me to follow the QuickStart guide and download all of the arduboy libraries (such as arduboy2, ArduboyTones, ArduboyPlaytune, etc) which I did. This worked and allowed me to upload castleboy. Now I am getting the same exact error when trying to upload hollow seeker, despite the fact that I’ve downloaded every library. I’ll check it out again later today to try to figure it out, but I am thoroughly confused right now.

You know, I had the same error when I first started trying setup my development environment in VS Code. I don’t know if I can help, but it might be similar to your issue. It wouldn’t recognize any Arduboy includes. I got frustrated and set myself up in VS Code with the PlatformIO extension and went on my marry way.

Are you on windows? Does this path exist? C:\Users%USERNAME%\Documents\Arduino\libraries\Arduboy2

Based on your earlier message it does sound like the libraries were not downloaded to the correct location.

Are you editing the code, or do you plan on it? You might be better served by using one of the uploaders.

What are the exact words of the error?

I’ve got a feeling that you might have downloaded Arduboy2 before,
and now Hollow Seeker is looking for Arduboy, which is a different, outdated library.

Hollow seeker uses the Arduboy library and not the Arduboy2 library. Are you sure you’ve installed that library?

Strictly speaking it can use either,
but to use the Arduboy2 library it would need an extra macro definition.

The getting start guide I referred the op to lists both Arduboy2 and Arduboy libraries.

Welp folks, I’ve given up on trying to download games with the guide and I’m just getting my games solely off of erwins arduboy collection now

As others have mentioned, unless you want to modify their source it’s better to use one of the game managers to upload the compiled hex files.

If you just want to upload hex files without changing them in anyway you can also use this tool I’m working on:

The pieces for creating and writing to the flash cart mod aren’t implemented yet, but it downloads an offline cache of erwin’s repo and allows you to upload individual games. This tool works with unmodded Arduboy’s as well and provides binary files for windows, linux, and mac that don’t require installation just extract and run it. There’s also a feature that allows you to recover an Arduboy that has a game with unusual upload requirements (caused from removing the USB stack for added program space) that just requires pressing the reset button with no precise timing involved (there’s a video on the post showing how to do this).

Progress is slow, but I’m working with @bateske and @eried to get this setup as the official game manager for the Arduboy ahead of the launch of the official FX mod.

Haven’t heard about that thing but sounds like a pretty compelling solution