Screen glitch problem when i upload some games [Solved]

Problem here
the screen turns like in the video in some games (i won’t survive and PONG)
why is it? i’ve checked the port and board and it’s correct

Did you compile the game yourself or are you using an uploader to flash the precompiled “.hex” or “.arduboy” files?

i compile every game in arduino, is it correct? for example PONG files is an arduino file.

It could be possibly you are compiling for a different screen type. The stock arduboy uses a SSD1306 OLED screen but arduclones (homemade arduboys) often use cheaper variants such as the SSD1309, SSH1106, etc which aren’t directly compatible with the stock screen. Where did you download the pong arduboy files? I can take a look to see if this is the case.

here

Nothing pops out at me other than it looks like it is using the older Arduboy libraries. The fact that the weird screen problem only happens with a few games sounds like it is either something specific to those games or your ide/library setup. I would contact @CDR_Xavier and see if he has insight and is willing to help figure out what is going on.

yes i think that it’s a library issue.

i will.

thank you

1 Like

Have you tried deleting ‘Arduboy’ from the libraries folder and redownloading it?

The libraries folder is usually Documents\Arduino\libraries on Windows.

No, i’m redownloading it

No, I wasn’t doing anything fancy that limits my program to a specific screen type.
In fact, it is not written in any format that is NOT normal.
Like these:

#include <Arduboy.h>
Arduboy arduboy;

//this is not screen specific, it just clears everything (stop them from being drawn)
arduboy.clear();
//this just update the screen
arduboy.display();
//this just draws a rectangle
Arduboy.drawRect(20,30,20,15,WHITE);

The only problem I can think of is your Arduboy.h, because it is the file that tells the microcontroller (ATmega32U4) the proper signal sent to the screen so it can display it.
The screen on Arduboy is SSD 1306, and if your library was altered to work with a homemade one with a different screen(like, SH1106), and these two screen driver require different signal, so when you compile it and upload PONG to Arduboy (with your library changed to SH1106 compatible), things will screw up.

BUT, you did remind me of having the need to have things moving to Arduboy2 library.
But I DO NOT like arduboy2 library…
But it is NOT my problem the game didn’t function properly… … … … … … …
@Pharap I think I wasn’t the one with sticky finger when typing code… can you check my Github?

@tfGamer, make sure you are NOT downloading the library from @Mr.Blinky, because he made certain changes to adapt to certain screen drivers…

@CDR_Xavier
The first thing I did when I originally read this thread was to compile and run PONG,
and I had absolutely no screen issues.

Plus if it was something you did, that would mean the people who made the other games made the same mistake, which seems unlikely.

@tfGamer stated in a previous thread that he ordered his Arduboy directly from the Arduboy store.
It’s not a clone of any kind, it’s the genuine article.

It’s less likely to be an issue with the games themselves and more likely to be a problem with either the library or the IDE setup.

My first advice to @tfGamer has been to delete the library and redownload it precisely because I’ve seen this problem before.

It seems that sometimes the libraries can sometimes get corrupted somehow.
If replacing the libraries doesn’t work then the next step will be to nuke the IDE and then reinstall it.

1 Like

Everything can be corrupted by the un-stability of internet.
Zip and video files are especially so.
Sometimes the computer CAN recover the data, but not if it is very densely-packed, and the library can be one of it, since it is used to MAKE hex file (though to me it don’t look too complicated)
I mean, just one character and something will be screwed up.

I actually meant to guess the opposite when talking about arduclones: I knew his was genuine but didnt know if the pong game setup for one of the clone oled screens. Sorry if I wasnt clear.

So you are suspecting that my same is written for clone screen?
The LIBRARY is responsible to decide where the code will be run.
did you download the library?
Lastly:
Try out my other entertainment software games to see if it is only the PONG or what


When having ASTEROID loaded, remember to flash another game onto it by using flashlight mode

Not that it was written specifically for a clone screen, but that it is possible that he might’ve selected the wrong library or the like.

library selection was through this:
#include <Arduboy.h>
and I wrote it.
Anyway, @sjm4306, let’s stop guessing and wait him to respond.

1 Like

GUYS, my problem is fixed… i’ve re-downloaded arduboy library and now it works fine… so yes it was a library’s problem.

2 Likes

See?
But yeah, you bumped into quite some trouble! (you upset the bootloader(of your arduboy) once, and you upset the library once)
Be more careful next time.

As expected.
It was almost certainly the same problem encountered on this thread:

Same symptoms, same solution.

This wasn’t @tfGamer’s fault, it’s something that just happens sometimes.
There’s no way they could have known about it or avoided it.

Well, he could’ve double checked before uploading the code (the bootloader thing)
Yes, unless you are a time traveler, you cannot know the library is wrong before not checking it (you should never waste time checking the library unless something is wrong) or uploading a game supposed to work…

and I will end this conversation here.