Scrolling Arduboy Screen

I haven’t used my arduboy in quite a while. This morning I went to go upload a new game and got a scrolling screen when I uploaded a new game. Could someone give me step by step instructions on how to fix this? On a Mac computer. Thank you

Update: New problem- I tried tinkering around and I bricked it… I tried following the video instructions and nothing happened. not sure what to do now… I do however have the red charging lights and the other two flash. No flashlight mode either.

I think that kind of a screen means you need to update your libraries on Arduino.

What did you do to “brick” it?

Have you tried using flashlight mode yet? Does Ardusnake have flashlight mode?

You should be able to use the reset button too. Try the troubleshooting guide:

‘Tinkering’ how exactly?

If I had to guess I’d say you probably had the IDE set to the wrong board when uploading.
It’s probably fixable, but fixing it might not be easy.
You’ll probably have to time the reset button.

Also it’s probably best to try uploading a ‘hello world’ program before you attempt uploading any games because it should take less time to upload and it’s a simpler program so there’s less that can go wrong.

#include <Arduboy2.h>

Arduboy2 arduboy;

void setup()
{
	arduboy.begin();
}

void loop()
{
	if(!arduboy.nextFrame())
		return;

	arduboy.clear();
	
	arduboy.println(F("Hello world"));
	
	arduboy.display();
}

Also as @bateske says, make sure all your libraries are up-to-date.

1 Like

I was able to figure it out. I updated all the libraries (didn’t see the update button) and tried again. Thank you guys!

1 Like