SkateArdDie! - Awesome

Awesome. I love this game

1 Like

Hi could you add in a little video

I recently added a Sprites class to the Arduboy2 library. This created a conflict with the Sprites class included locally in SkateArdDie. This causes a compile error:
sprites.h:29: error: redefinition of 'class Sprites' - error

I’ve made modifications to SkateArdDie to switch to using the Arduboy2 Sprites class. My new version can be found here.

I’ve created a pull request for the changes, so hopefully the original will be updated (if my fix works properly).

I merged the pull request :slight_smile: thanks!

1 Like

when my arduboy arrives I playing this!

Is anyone else having the problem where when you put the game onto the arduboy, it doesn’t let you put another one on. if so and if you were able to change the game, please tell me how to.
I am on a macbook.

Have you tried flash light mode?

Have you tried pressing the reset button?

flashlight mode is not turning on.

Oh … I can see in the code they have not enabled that. Nasty.

Try the reset method.

neither are working this is the error thing that shows btw i dont know how to shrink it, so srry

Arduino: 1.8.5 (Mac OS X), Board: "Arduboy"

/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -dump-prefs -logger=machine -hardware /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -hardware /Users/ajcombs/Library/Arduino15/packages -tools /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -tools /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -tools /Users/ajcombs/Library/Arduino15/packages -built-in-libraries /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -libraries /Users/ajcombs/Documents/Arduino/libraries -fqbn=arduboy:avr:arduboy -vid-pid=0X2341_0X0036 -ide-version=10805 -build-path /var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_build_3807 -warnings=none -build-cache /var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_cache_135973 -prefs=build.warn_data_percentage=75 -verbose /Users/ajcombs/Documents/Arduino/PONG/PONG.ino
/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -compile -logger=machine -hardware /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -hardware /Users/ajcombs/Library/Arduino15/packages -tools /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -tools /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -tools /Users/ajcombs/Library/Arduino15/packages -built-in-libraries /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -libraries /Users/ajcombs/Documents/Arduino/libraries -fqbn=arduboy:avr:arduboy -vid-pid=0X2341_0X0036 -ide-version=10805 -build-path /var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_build_3807 -warnings=none -build-cache /var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_cache_135973 -prefs=build.warn_data_percentage=75 -verbose /Users/ajcombs/Documents/Arduino/PONG/PONG.ino
Using board 'arduboy' from platform in folder: /Users/ajcombs/Library/Arduino15/packages/arduboy/hardware/avr/1.0.0
Using core 'arduino' from platform in folder: /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/
Detecting libraries used...
"/Users/ajcombs/Library/Arduino15/packages/arduino/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega32u4 -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_ARDUBOY -DARDUINO_ARCH_AVR  -DARDUBOY_10 -DUSB_VID=0x2341 -DUSB_PID=0x8036 '-DUSB_MANUFACTURER="Unknown"' '-DUSB_PRODUCT="Arduboy"' "-I/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/" "-I/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/" "/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_build_3807/sketch/PONG.ino.cpp" -o "/dev/null"
Generating function prototypes...
"/Users/ajcombs/Library/Arduino15/packages/arduino/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega32u4 -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_ARDUBOY -DARDUINO_ARCH_AVR  -DARDUBOY_10 -DUSB_VID=0x2341 -DUSB_PID=0x8036 '-DUSB_MANUFACTURER="Unknown"' '-DUSB_PRODUCT="Arduboy"' "-I/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/" "-I/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/" "/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_build_3807/sketch/PONG.ino.cpp" -o "/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_build_3807/preproc/ctags_target_for_gcc_minus_e.cpp"
fork/exec /Users/ajcombs/Library/Arduino15/packages/arduino/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++: no such file or directory
Error compiling for board Arduboy.

Sorry I am not sure what that error is.

Have you tried compiling games other than Pong? Maybe try the sample HelloWorld? (yes I am clutching at straws)

i tried hello world from both arduboy 1 & 2 from examples, that did not work, (i did both no reset and a reset) i think it might be my computer, but i have completely shut down my computer 2ce, and deleted and then re-downoalded it.
so, should i try removing all the arduboy libraries & boards?

the arduboy is showing up and i can select it and the screen is still working, and i can play the game. so i do not know what is happening, im going to try using a different computer? i am not sure that would work though.

maybe i could try letting the battery drain on it then charge it up? im really grasping for straws here, cus i got it only 15 days ago.

Humour me, can you try to upload Hello World again but this time ensure the device is visible (in the IDE got oto ports and make sure it is selected) and change the board to Leonardo (not Arduboy).

That did not work, I believe the problem is my computer, not the Arduboy

Have you got a longer error message available?
Have you turned verbose compilation on?
(File > Preferences > Compiler warnings: All)

Have you tried nuking your library folder and reinstalling all the libraries?

And failing that have you tried nuking your Arduino IDE install and reinstalling it from scratch?

Yes to all of it, did not work, the arduboy & arduboy 2 is not showing up in examples, I think that’s the problem, but I forget how to get it to show them

If the examples aren’t showing up then it sounds like the libraries aren’t installed properly or can’t be found.

I have no idea where they get installed on a Mac though.

I’m just going to watch the video I used after removing everything