SkateArdDie! - Awesome

flashlight mode is not turning on.

Oh … I can see in the code they have not enabled that. Nasty.

Try the reset method.

neither are working this is the error thing that shows btw i dont know how to shrink it, so srry

Arduino: 1.8.5 (Mac OS X), Board: "Arduboy"

/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -dump-prefs -logger=machine -hardware /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -hardware /Users/ajcombs/Library/Arduino15/packages -tools /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -tools /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -tools /Users/ajcombs/Library/Arduino15/packages -built-in-libraries /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -libraries /Users/ajcombs/Documents/Arduino/libraries -fqbn=arduboy:avr:arduboy -vid-pid=0X2341_0X0036 -ide-version=10805 -build-path /var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_build_3807 -warnings=none -build-cache /var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_cache_135973 -prefs=build.warn_data_percentage=75 -verbose /Users/ajcombs/Documents/Arduino/PONG/PONG.ino
/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -compile -logger=machine -hardware /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -hardware /Users/ajcombs/Library/Arduino15/packages -tools /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -tools /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -tools /Users/ajcombs/Library/Arduino15/packages -built-in-libraries /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/ -libraries /Users/ajcombs/Documents/Arduino/libraries -fqbn=arduboy:avr:arduboy -vid-pid=0X2341_0X0036 -ide-version=10805 -build-path /var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_build_3807 -warnings=none -build-cache /var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_cache_135973 -prefs=build.warn_data_percentage=75 -verbose /Users/ajcombs/Documents/Arduino/PONG/PONG.ino
Using board 'arduboy' from platform in folder: /Users/ajcombs/Library/Arduino15/packages/arduboy/hardware/avr/1.0.0
Using core 'arduino' from platform in folder: /private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/
Detecting libraries used...
"/Users/ajcombs/Library/Arduino15/packages/arduino/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega32u4 -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_ARDUBOY -DARDUINO_ARCH_AVR  -DARDUBOY_10 -DUSB_VID=0x2341 -DUSB_PID=0x8036 '-DUSB_MANUFACTURER="Unknown"' '-DUSB_PRODUCT="Arduboy"' "-I/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/" "-I/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/" "/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_build_3807/sketch/PONG.ino.cpp" -o "/dev/null"
Generating function prototypes...
"/Users/ajcombs/Library/Arduino15/packages/arduino/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega32u4 -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_ARDUBOY -DARDUINO_ARCH_AVR  -DARDUBOY_10 -DUSB_VID=0x2341 -DUSB_PID=0x8036 '-DUSB_MANUFACTURER="Unknown"' '-DUSB_PRODUCT="Arduboy"' "-I/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/" "-I/private/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/AppTranslocation/CC166641-2815-4A90-B9E9-7A6D43B97199/d/" "/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_build_3807/sketch/PONG.ino.cpp" -o "/var/folders/hf/72kywnp53fs5_q_2rpf8z6gr0000gn/T/arduino_build_3807/preproc/ctags_target_for_gcc_minus_e.cpp"
fork/exec /Users/ajcombs/Library/Arduino15/packages/arduino/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++: no such file or directory
Error compiling for board Arduboy.

Sorry I am not sure what that error is.

Have you tried compiling games other than Pong? Maybe try the sample HelloWorld? (yes I am clutching at straws)

i tried hello world from both arduboy 1 & 2 from examples, that did not work, (i did both no reset and a reset) i think it might be my computer, but i have completely shut down my computer 2ce, and deleted and then re-downoalded it.
so, should i try removing all the arduboy libraries & boards?

the arduboy is showing up and i can select it and the screen is still working, and i can play the game. so i do not know what is happening, im going to try using a different computer? i am not sure that would work though.

maybe i could try letting the battery drain on it then charge it up? im really grasping for straws here, cus i got it only 15 days ago.

Humour me, can you try to upload Hello World again but this time ensure the device is visible (in the IDE got oto ports and make sure it is selected) and change the board to Leonardo (not Arduboy).

That did not work, I believe the problem is my computer, not the Arduboy

Have you got a longer error message available?
Have you turned verbose compilation on?
(File > Preferences > Compiler warnings: All)

Have you tried nuking your library folder and reinstalling all the libraries?

And failing that have you tried nuking your Arduino IDE install and reinstalling it from scratch?

Yes to all of it, did not work, the arduboy & arduboy 2 is not showing up in examples, I think that’s the problem, but I forget how to get it to show them

If the examples aren’t showing up then it sounds like the libraries aren’t installed properly or can’t be found.

I have no idea where they get installed on a Mac though.

I’m just going to watch the video I used after removing everything

@Yank33doodle I have been attempting to work on your issue for some time now. Knowing that mac has several issues with Arduino ports, boards, etc. I dusted off my mac and decided to give it a try.

I receive the same error code: Error Compiling for Board (selected board).

I decided to open board manager, then I chose the first and only board installed: Arduino AVR Boards, and (assuming you have the most up to date version of Arduino AVR Boards) I selected and installed the previous version (from 1.6.21 to 1.6.20). This now verifies, complies and uploads sketches successfully. With the updated version 1.6.21, I was having the same issue that everyone seems to encounter.

Board: Arduino Leonardo
Port: Once Arduboy is plugged in and recognized successfully, I chose the Leonardo port (not Bluetooth)

Assuming this may not fix the issue for every game, I would also suggest trying reset option when trying to upload new sketch (try without reset first)

If you changed the version of board to previous version and it still won’t verify/upload (without Arduboy Plugged in) and just shows error message, I assume my fix above will not work.

Please let us know if anything different is happening! Hope you get it up and running soon!

1 Like

What do you mean by that, what do I download

Tools>Board>Board Manager

Then should be first board labeled ‘INSTALLED’ (Arduino AVR Boards) click on this and select version 1.6.20. it will uninstall most up to date board and install version you selected (1.6.20)

Then try to verify any sketch or example (if you got examples back)

1 Like

Thank you so much, that worked. I never would have thought of that. Thank you


I hope you get/got a new game on there! I don’t remember if I read about changing boards when I searched the problem in google, (I don’t want to take credit for the fix if it is already online) but I looked through several forums and came up with something!

1 Like