Sleeping Arduboy

Hello,

At first I thought that it was just the battery but when I plugged it, nothing happened.
If I turn it on while charging the red led is on but the screen stays black and there’s no sign of life throught USB. Same thing if I turn it on while pressing the up or reset button.
I tried another USB cable or port, same result.

I’d be glad if someone could help me waking him up.
Good day
Ced

Try the small reset button next to the Micro USB plug. Push it while device is on for some seconds and then release. Device should live up again.

I tried pushing it for 10s while keeping an eye on the “Port” option in the compiler, it stays grayed.

The port option does not update when the option menu/port is open. you need to close the menu again before it is updated.

If you’re on windows a better way is to open device manager. when you release the reset button a ‘Arduino Leonardo Bootloader’ port will pop up under ports for 8 seconds. During that time you can upload a new/blank sketch.

For easier timing an upload. Enable verbose output on upload in preferences. Then when uploading a blank sketch look for ‘com port ()()’ repeatedly listed in the black log area. When that happens press and release reset quickly.

Thank you for trying to help but it looks like my Arduboy needed a very long night…
No new device detected by device manager when I press reset. by the way there is no more familiar “some USB connected” sound.

I don’t know if it can help debug but when I plug the USB while it’s off, the red LED turn on for a split second then remains off.

Is it possible that the reset button has been damaged and is short-circuited? I can still hear it click but you never know… What happend when it is always pressed?

The red LED is part of the charging hardware. It lights up when the Battery is being charged.

If you have another USB cable try that one. A lot of USB cables you get are just charging cables and won’t work with Arduboy (other then charging) or confirm your USB is a data cable by connecting another USB device to your PC and read data from the device.

It is unlikely the reset button is shorted or hangs (it would sooner snap off).

1 Like

Ok, i found the problem when I disassembled my Arduboy. The bridge between the battery and “(+) BAT” is broken. I will try to solder it at work.

1 Like

Be very careful, the LION battery could explode due to the heat.

Ok, thanks for the warning

A random guy on the internet who clearly knows more than me also advises against it:

It can cause “thermal runaway” apparently,
which may or may not look something like this:

(Also there’s several good videos of what happens when you put batteries in a microwave,
though that’s not entirely relevant. :P)

As long as it’s the solder joint that’s broken, re-soldering it should be OK as long as you don’t let things get hotter that is just necessary for a good joint (to prevent the risk of explosion, as others have pointed out).

If the break is anywhere else, it may not even be possible to solder it because the lead exiting the battery is made out of a metal that won’t take solder.

Here’s a picture:


The crack is on the left bridge. Is this the metal you were taking about ?

Maybe I can melt both pads and slighlty twist the battery so even if the broken bridge is shorter it will be inside the tin.

To solder there should not be a problem. Just as mentioned keep temp low and do not leave the iron too long on it.

Yes. Solder may not “take” at the point of the crack, as can be witnessed by the fact that solder didn’t wick up to that point when it was first soldered.