[SOLVED] Arduboy port doesn't appears


(Skuratovich Sergey) #1

Hello!

Suddenly realized that I could not upload anything to my arduboy any more.

When I plug it to my desktop only the red led is lighting up (then switching off after some time). TTY device doesn’t created in the /dev folder. There is no new messages appears when I call dmesg and lsusb output doesn’t change as well.

I have tried different cables including those which worked fine earlier. Desktop software and hardware was not change since I last time use it to upload games.

Current game on arduboy: Mini Rogue from @eried repository uploaded with Arby Utility. I have used Arby Utility many times before without any problems.

Any suggestions how to fix that? Is it a software or hardware problem?


(Stephane C) #2

We should add a note on the repo. When on the title screen, press and hold the down arrow, this will trigger the bootloader mode and you will be able to upload a new game without problem.

In order to have more space for the game we had to remove the USB stack.

Doing what I just talked about should solve your issue.


#3

There’s a number of games that require something like what @vampirics mentioned as well. If it happens again you can search here for the games thread. It should have information on reflashing. Worst case you can also try the reset button, but be careful it’s fragile and more of a final option.


(Skuratovich Sergey) #4

Thank you. Holding down arrow while switching arduboy on solves the problem.