[Solved] Arduino IDE not uploading to Arduboy


#1

I am trying to upload to my Arduboy and I keep getting this error message:

processing.app.debug.RunnerException
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:160)
at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
at processing.app.SketchController.upload(SketchController.java:713)
at processing.app.SketchController.exportApplet(SketchController.java:686)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2168)
at java.lang.Thread.run(Thread.java:748)
Caused by: processing.app.SerialException: Error touching serial port ‘COM6’.
at processing.app.Serial.touchForCDCReset(Serial.java:107)
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:144)
… 5 more
Caused by: jssc.SerialPortException: Port name - COM6; Method name - openPort(); Exception type - Port not found.
at jssc.SerialPort.openPort(SerialPort.java:167)
at processing.app.Serial.touchForCDCReset(Serial.java:101)
… 6 more

I tried holding the reset button while uploading, double pressing doesn’t do anything at all and no threads that I have found have had a similar issue. I have spent over 2 hours trying to fix my Arduboy, but nothing has worked. :tired_face: I would really appreciate some help. Thanks! :wink:

Note: I fixed it :slight_smile:


(Simon) #2

How?      


#3

I realised that I had my screen capture for my Arduboy running, and for some reason, my screen capture program prevents the Arduboy from uploading when it is running.


(Simon) #4

Oh that’s interesting.

I am not sure if you have used ProjectABE locally but a similar thing happens. I assume that when the IDE looks for the Arduboy it finds the ProjectABE device running and uploads to that.


#5

Probably the case. It was just hanging on the upload screen, so I closed the IDE and re-opened it.


(Pharap) #6

When you say “screen capture”,
do you mean a normal screen capture program for recording a part of your computer screen,
or do you mean one of the programs that’s designed to transmit the Arduboy’s screen contents to your computer over USB?

If you mean the former then I’m stumped.

If you meant the latter then the answer is pretty simple:
the Arduboy screen mirroring program is hogging the serial port.
When you upload a program to Arduboy it’s uploaded over a serial connection,
and that same connection is used for Arduboy ‘screen mirroring’ programs,
and you can only have one thing using that connection at any given time,
hence why the screen mirroring program would be interfering.


#7

I meant a screen capturing program for my arduboy. thanks for clearing that up!:grin: