[Solved] Bricked Arduboy?

Hello,
when i uploaded sketch probably bricked my Arduboy.
The only signs of life is green LED when turned on like in a movie.

This sketch that I uploaded previously worked on this arduboy.
I tried to reset Arduboy with small button on the left of microUSB port.
I tried start with UP_KEY. Nothing helps.
The green LED still lights up for a few seconds after switching on.

Upload sketch on Arduino 1.8.5 on ArchLinux with Arduboy Board and AVRISP mkll.
Device is not present i dmesg.

Any ideas how to fix it? What does this GREEN LED mean?

Which game did you have on the device and which game did you tried putting on the device?

2 Likes

When you press the reset button your Arduboy will enter bootloader mode for uploading a new sketch. However this mode only remains active for about 8 seconds. so you have to time carefully when to press reset.

Hard to tell. It’s turned on and off by the bad sketch you’ve uploaded.

Try to browse / search the forum on how to fix upload problems. It has been asked and solved before several times (Sorry don’t have a link at hand atm).

2 Likes

Actually. The time was too big between the reset button and the upload sketch.
I tried again and succeeded. Thank you all for your help!

4 Likes

Great to hear that your Arduboy is back to working condition!

1 Like