(SOLVED) Can't load any sketch which after can load

I can’t load any sketch which after can load, any idea???

Thanks and sorry about my english.

I think it is because you have not installed the arduboy library. To install it, you need to go to sketch/include libraries/manage libraries. A screen should pop up and type this in the search bar: arduboy and install the library arduboy called arduboy. Then, your sketch should compile with no troubles. If You are using Arduino 1.1.0 then go to https://www.arduino.cc/en/Main/Software to install the newest version of Arduino. Let me know if it doesn’t work then just reply to my post. Bye!

1 Like

Library is installed.

Thanks for your help.

If this is about the problem:

Caused by: processing.app.SerialException: Error usando el puerto “/dev/ttyACM0”

You have a connection problem:

  • have you ever been able to upload a game?
  • did you select to correct port in the ARDUINO IDE ?
  • are you using a data cable ? (some cables can only be used for power)
1 Like

Yes, I was able to upload a game.
Yes, correct port selected.
Yes, I’m using a data cable, with this one I upload games before.

(sorry about my english)

You’ll have to use the reset trick. Gently push the reset button with a paperclip just before uploading, or just after you pressed uploading. You probably will have to try several times.


1 Like

I’ve already tried it. Arduboy turn off and them turn on, and still works in the same way. I´m afraid it is not the solution.

Here you can see whath happen …


I got it! Sometimes when you try to upload a game that happens. You can fix that by : compiling your sketch, then hold down the reset button and then upload the new game and release the button and it should upload. If it doesn’t work, then I will post a video. bye !!

1 Like

I try it and it doesn’t work. Can you please upload a video? I don’t know if I do it right.

@RamonML just a question, but do you know where the reset button is? it’s that small hole on the bottom. Just asking to be sure you know where to find it.

1 Like

Yes, I know where is it, at the left side to the usb.

Hold on, I am going to post a video soon.

1 Like

Thanks, I will be attentive to your comments

ok good ! @RamonML this has happend even to me and it can be fixed !

  • Do you remember if the com port you selected before was /dev/ttyACM0 ?
  • it is really tricky to get the timing correct for pushing the reset button
  • press upload and then the reset button (one push, not holding)
  • if it failed, try again a little bit sooner
  • if it failed, try again a little bit later
  • really try again (the first time I had to try like 20 times before I got it right, don’t give up)
1 Like

So, first compile the sketch and then hold down the reset button until the screen goes black and then release the button and quickly upload the sketch and it should work.

1 Like


It looks like the game you currently have loaded is Fatsche. Did you see the note that was included for it?


IT WAS THE SOLUTION!!! (Sorry caps)
Thank you very much for your help.


that worked :wink: thanks