SOLVED: Can't understand if not recharging or bricked

Hi all.
I’m an early kickstarter backer of Arduboy, received it about 15 days ago.
Yesterday night, working on my little game and usb connected to my macbook, it suddenly stops work (i don’t remember if while uploading or something else).

If i turn it on/off, no signs of life.
If i reconnect it trough usb, only the red led of three in the bottom left turn on, however the Arduboy was on or off.

Is there a way to understand if is battery fault or something else?

Thank you
Regards

Edit: obviously i had tried with reset button, no luck

Red LED is the charging light iirc? You need to flash some known working code on to the arduboy to recover it - using the rest button and one of the arduboy library example games. Follow these steps:

  1. Plug in arduboy to pc, turn it on
  2. Open arduino IDE
  3. Press reset button, and quickly look in ‘port’ section of the menu to find the port the reset arduboy will be in and select it. You need to be quick for this, but it’s easier than trying to do the next bit and this all in one go!
  4. Compile one of the example programs.
  5. Hit reset again, then the flash button. With good timing and some luck, you should be able to resurrect your arduboy.
    If step 5 fails/it doesn’t flash/etc. you may have missed the window, keep trying, you should get it eventually. I killed mine on day one and spent about 2 hours trying to find a way to save it before stumbling across the above method.

Thank you for your reply.
Yes i think that is the red charging led.

I had tried with reset button but no led start blinking, but as you suggest i’ll try to see if it appears as a port so i can select it and then reupload some code.

I will let you know.

If the last sketch you successfully loaded uses the standard Arduboy library and it calls arduboy.begin() here’s something else to try:

Press and hold the Up button while powering on the Arduboy. This should cause it to enter “flashlight” mode and the RGB LED will light up white. If the LED lights up, then your Arduboy isn’t totally bricked. You can then try uploading one of the example sketches while in flashlight mode (don’t push the reset button).

2 Likes

It come back to life!

What i was missing in my first tries was that when in reset mode no led blinks and you had to be fast to choose the port in arduino ide.

Thank you for your help!

3 Likes