[SOLVED] DIY Arduboy crashing/glitching

Hi all!

I have made a DIY Arduboy to the schematic seen below, I have burnt the bootloader and am able to write to the flash card.

After scrolling through the menu, selecting and playing some games, my device encounters some glitches. Certain games will cause it to crash, sometimes it shows the USB boot symbol, and other times it shows a pixelated screen.

Is there something I have missed with my hardware setup perhaps?

Happy to be a part of this amazing community and thank you so much for any info provided :))

Hi! one thing I see is that you have no 10K pullup resistor on SDA instead you put a 1K resistor in series with SDA and flash chip select. Try connecting a 10K resistor between VCC and SDA.

1 Like

Okay cool would I wire it like this? (is my 1K resistor no longer needed)?

I appreciate the help :slight_smile:

Yes but you’ve added a 10K variable resistor (symbol/part) for R2. just use a regular 10K resistor.

R1 is not needed.


Amazing! I removed the 1K and added the 10K as you instructed and now it works perfectly! Thanks very much :))


Hi sorry to bother! but I have encountered another problem. I purchased some new 2.42 inch oled from the brand DIYMORE. I am experiencing glitching when using the screen on the left (this is the new one) yet it works perfectly with the screen on the right. Is there something I need to change on the rear of the DIYMORE? Thanks!!