[SOLVED] DIY Arduboy not fully working with a sh1106 oled

So my arduboy is having screen issues the game seems to work but nothing shows on a screen .
Control Keys:

UP - A0




A - D7

B - D8

OLED Display:

SCL - D15

SDA - D16

DC - D4

RES - D2





RED - D10



I designed a pcb in easyeda and the console first worked with a ardu-man game but when i uploaded other games it didn’t work but now it doesn’t work with the ardu-man anymore .

Well, what development board/processor are you using? Got any images?

Might also be useful to know that in order for games to work on an sh1106 display, you have to recompile games using @Mr.Blinky 's homemade package: GitHub - MrBlinky/Arduboy-homemade-package: Arduino IDE board package for Arduboy and homemade versions making things easy

im using a arduino pro micro and i already have the library

Not sure what could be happening then. Are you getting any error messages of sorts?

1 Like

no it just uploads and im getting noise and everything but no image

I don’t think it’s an issue with the library then-pixels would still show but be warped (at least it was like that for me). Are you sure you’ve connected your display correctly?

it worked before so i don’t think it is an issue but can it be that a 1.3 inch oled with spi could be something else than sh1106

That’s what I meant earlier as an issue with the library, but yeah, possibly. Have you checked the description/specs of the place you bought it from?

i did it doesnt say anything about it but pepole commented it is an sh1106

Maybe the display could be broken then :man_shrugging:. Can you try a game you’ve already tried?

here i have some pictures from now and one from when it was ok

1 Like

1 Like

Might be a compiling issue then. I’m not the best at this sort of stuff though.

Can it be because i cleared the eeprom and it effed up?

is anyone still reading it

Yes I was reading. But I didn’t understand your problem properly though.

my games are working i have the sound but no image

there is a problem with uploading games because not all of them work

is there a way to reset an arduino to complete stock