[Solved] Do I have to flash it? After reset is not recognized by Windows

Hi,

I received my Arduboy a week ago and I really love the form factor. However now when I start to upload a game, the screen stays black, and there is a red light. Resetting with a paper clip does not help either.

A few things you can try.

Hold up on the D-Pad when you turn on the arduboy, this should boot it in flashlight mode (It will start with a white screen). It should then work as normal.

If this doesn’t work, the reset with the paperclip only gives you a couple seconds in bootloader mode, so you cannot just wait about. Use the following process.

Create a new arduboy sketch. Stick the following into it so you know it is working.

Arduboy arduboy;

void setup() {
    arduboy.beginNoLogo();
}

void loop() {

 if (!(arduboy.nextFrame()))
    return;

  // first we clear our screen to black
  arduboy.clear();
  arduboy.setCursor(0,0);
  arduboy.print(F("ok?")); 

  arduboy.display();
}
  1. Attach your arduboy to your PC.
  2. put your paperclip into the reset slot, but don’t push the button yet.
  3. Press the reset button and right away hit compile and upload (ctrl+U or cmnd+U).

This should all happen within the reset grace period, so you should see the text saying ‘ok?’

The thing is that the Arduboy is detected normally (COM5) and in flashlight it is the same, everything is OK there. But when the upload starts, the Arduboy resets and then it is no longer detected by Windows. Same thing if I manually reset it, it is just not detected anymore and Windows tells me that it is an unrecognized device. The upload fails.

Even with the second technique i mentioned? Uploading the small sketch right after reset?

Yeah, Arduino even resets the Arduboy on the upload like it should, but after the reset the board does not appear with another COM port anymore for some reason.

“Couldn’t find a Board on the selected port. Check that you have the correct port selected. If it is correct, try pressing the board’s reset button after initiating the upload.”

Hmm, I;m out of ideas for now. There are other more knowledgable people here who hopefully can help. Also other people have had this problem and resolved it, so check the other posts if you haven’t already

I checked and I guess I need to flash it buying a usbasp and soldering the corresponding pins at the back. Too bad :frowning: I started to see some corruption in the bootscreen yesterday but I am not sure if it is related.

Did you try with another USB port? What about a different cable? Are you using a USB hub? Are you using flashlight mode? Did you try another computer?

I am going to test it in another PC but I might need an ICSP programmer :frowning:

Everything works, but in programming mode it is basically dead. No USB descriptor at all

The only reason you would need a programmer is if your bootloader is corrupted. If you can get into flashlight mode then the sketch is executing, so the bootloader is probably OK.

Thanks, it is the retail.

The thing is that after pressing reset there is no USB descriptor or anything, it is completely undetected as a plugged device, like windows it is just providing power. I am going to try in another PC several more times but I don’t see this problem is somehow documented here :confused:

Too bad, arduboy it is so cute and nice! I hope it comes to live again.

Just to be sure: Your Arduboy should be powered on when uploading. Is it?

1 Like

Yes, it is on. I was starting to learn to program a game (In my company sometimes they give away some little internal prices, I was thinking it would be nice to give away an Arduboy with the company as a game inside :smiley: ) but after some trials I saw the bootscreen glitched out (some garbage pixels) and now it is dead if I reset it.

Here it is a capture of what it happening:

I use Linux, so I don’t know if I can be of much further help. It could be a problem with the Windows driver. Is there anyone reading this who knows what the errors indicate?

for one thing your selecting the wrong board, you should be selecting board arduboy, ( if that board is not in your list download it in the board manager)

the PORT should say arduino leonardo but the BOARD should say arduboy

As the Quick Start Guide mentions, you can select Arduboy or Arduino Leonardo as the board type. Either selection will work fine.

1 Like

well i tried to help, thank you for correcting me

This is pretty odd, looks like possibly the USB ID may have got corrupted somewhere along the line. If you don’t feel comfortable with reprogramming the device (you can also do it with another arduino if you have one) please let us know at the contact page www.arduboy.com/contact and we can try to help you from there.

1 Like

Thanks everybody, I think I am screwed :frowning:

Mine suffers that same problem… :confused:

I already sent some details using “contact us” @bateske and waiting for their answer now. Thanks for the advice. So depressing to see the little dude sick like this, not wanting to play games lol hahaha

Not likely, since the IDE is showing (Arduino Leonardo) beside the port name, which means it’s talking to the Arduboy, reading the IDs and recognising it as a Leonardo.