[SOLVED] Homemade arduboy not uploading games

Hi, I just made my first arduboy … its a mess of tape, that’s right tape I did not have solder so I used tape it works fine expect when I try to upload a game using Mr. blinky homemade arduboy board package or just any arduino sketch it gives me a problem the upload is stuck and the bootloader of the spark fun pro micro(clone) does not connect to the arduino, I know this because the com port number does not increase by one, it resets and goes to port 10 which is the exact same port as before. I also am using a SSH1106 display which works fine because I tested it by uploading a game but I cant upload new games i am using the default bootloader of SparkFun Pro micro. does anyone know why I can’t upload new games, I have tried resetting the arduino manualy when its done compiling and about to upload the com port number does incresse by one when i do so for 8 seconds. BTW if you need images of the connection I cant send you it because the sparkfun pro micro is covered in tape

It sounds like you might have installed a game that removed the USB auto reset code.

Which game is it? You might try holding the up button while you turn on the power, and see if you are able to put it into a recovery mode. But without the auto-reset code this won’t work either.

The reset button method will always work, but getting the timing correct can be difficult. I usually press upload on Arduino and then press reset on the Arduboy after it starts trying.

You may also check your connections, it’s possible that perhaps a wire became disconnected and is causing a short that is preventing the correct operation of the device.

MicroTD Miloslav Číž / MicroTD · GitLab

I usually press reset after arduino ide writes “sending 1200 bps signal”
it always works but not this time also I checked all the wiring

What happens when you turn on the device? Do you show the bootloader menu or does it go straight into the game or is just a black screen?

If you are in the bootloader menu it really should reprogram, I can’t think of any reason it wouldn’t.

Can you take a picture or video of the operation?

no i don’t have serial flash and when i turn the device on it start’s the game the first I programmed into it

the screen works like it should

Is the port visible during playing the game, and then when you press reset, you don’t see the bootloader port?

It could potentially be that the bootloader is corrupted, it sort of sounds like it. But it is very difficult to do - but not impossible, I’ve managed it a few times.

Did you burn a new bootloader onto it? Or have any high voltage/short circuit events? Maybe disconnected usb during an upload?

It’s difficult to say - especially with it being a home made, the only thing that comes to mind is swapping out the chip, but it sounds like you’ve got it assembled in a way that’s not easy to take apart.

Another thing to just try: different usb cable.

no that cant be because i can upload a sketch on to the board expect only those which are fro arduboy dont work. I tested this by uploading a blink sketch it worked

when i got the board the person that soldered all the components put solder between - and + contacts of a capacitor but i sovled that before

I tryed 6 and thats all I got

honestly taking apart soldered components is the hardest job for me

So you you use the same IDE, with the same configurations and you are able to upload a blink sketch, but if you chose an arduboy sketch it doesnt upload?

If you are able to successfully upload other code, then there is nothing wrong with the hardware - the problem should be how your PC is configured.

The side note to that is potentially if you’ve wired it wrong, there are several ways to hook up this display with this controller and all of them require you to make sacrifices to the performance of the device. I don’t think any of them should prevent the uploading of new code, especially if you are able to see the com port.

@Mr.Blinky would be the expert on this to troubleshoot it further, but it sounds like to me that some configuration on your PC would be the issue. Unfortunately I don’t know enough about the alternative display and wiring so can’t be of much help there.

Oh sorry I missed this, this can very easily destroy a board. I suspect this is what has happened but the resulting effects of the damage to the silicon only happens under certain circumstances.

Sorry I think your board fried.

So you can put the Pro Micro into bootloader mode by manual reset. It exits after 8 seconds as this is the normal timeout.

Try this:

  • In the Arduino IDE, enable verbose output for upload
  • upload your sketch normally
  • when you see a bunch of COM messages appear, reset the Pro Micro manually.
  • The Arduino IDE will now detect the bootloader COM port and will start uploading.

I was able to upload a new game on to it!

Nice work blinky! I guess enabling verbose mode can make it a little more obvious when to hit reset, thanks for the tip!