[Solved] I uploaded Choplifter to my BRAND NEW Arduboy and now no other games will upload

What can I do? It’s BRAND NEW. :frowning:

I fixed it using Flashlight mode… weird…

Press the up and hold the up button when turning the device on. You should then be able to upload another game.

Alternatively, when the IDE is about to upload press the rest button (it can be …

Half way through typing and you fixed it. It is because Choplifter passes the magic 75% of RAM useage.

2 Likes

Interesting. I’m still learning how this thingy works. Thanks Filmote! :smiley:

2 Likes

We really need to get a sticky post explaining ‘flashlight mode’.

It’s such common knowledge among the regulars we forget that people turn up not knowing it by default :P.

1 Like

Yeah, it would be useful.

Is @minifig a lego reference?

1 Like

@Filmote Yup, it sure is!

1 Like

My son is Lego mad. He has a lot of new lego and some of my own from BITD. I have minifigs with non-moveable arms and legs like the ones below:

MiniFig

2 Likes

:open_mouth:

I’d LOVE a pair of those…

They’re hard to find now days.

Mine are nicer than these … blue / red and not chewed up.

BTW, sorry about the scare with Choplifter. I wrote it so I felt a little guilty it was causing you problems. How did you find the game?

http://arduboy.ried.cl

1 Like

I meant, how did you find the game to play?

It’s hard… but it brings back nostalgia of my Sega Master System. :slight_smile:

Were you playing easy or hard ?

That’s a good source, lol (I can also do some filmoteing ).

What is the point of skipping the boot thing in choplifter?

1 Like

It already has maximum memory problems … the begin() uses up a few bytes and I am not a big fan of the Arduboy logo.

1 Like

@filmote forgot one - not being blinded by horribly bright LEDs :D

2 Likes