SOLVED: My Arduboy Devkit no longer works on battery power

My trusty devkit has suddenly stopped working on battery power. I haven’t done anything different with it, just the usual routine of putting games and demos onto it. Then today when I put Epic Crates of Mass Destruction on it, it no longer works unplugged.

It works fine when plugged into USB. I get no response to using the power switch at all. I’ve tried multiple new batteries.

Do I have a hardware problem, or could this somehow be software related, and fixable? Any help greatly appreciated!

Thanks

Sounds like a failure to me, but maybe it’s something simply you could fix

Thanks for replying Josh. I don’t suppose you know how I might diagnose whether this is a hardware thing I could simply fix or find out if it’s worse than that? I can’t see any obvious issues in the exposed circuits on the board, and the unit hasn’t been subjected to any knocks either.

Thanks for opening an issue @Cavelander, lets see if we can ping @bateske in here. It does seem there may be some fault with the hardware. I honestly couldn’t say if there is a replacement dev kit out there, I wonder if the traces an be pinned out for continuity between the switch and the battery or the usb port and the battery.

If i had to make a wager, I would say a trace to usb has been worked loose. This may be a situation where reflowing some solder may fix this. I don’t know what the specs are on the screen for heat, but often you can put circuit boards in the oven to try and reflow some of the solder.

If you have a multimeter, and If @bateske ever gets around to publishing the DevKit schematics and board files, I might be able to help you out with determining the problem.

I don’t have a DevKit myself to use as a reference.

Thanks for helping out guys. I guess step one is definitely to get a multimeter and check the battery connectors. I report back after I do that.

These CR2016 coin cell batteries for the developer kit are not rechargeable. Odds are the battery is dead.

A typical CR2016 will power a Developer Kit for about 4-5 hours depending on the quality of the battery. I buy some cheap ones here in China that last less than an hour.

You can actually find rechargeable cells in this size their part number is LR2016, but we do not have a charging circuit on the developer kit so you would have to do that outside the device.

In all circumstances it is not recommended to power the arduboy by usb with the battery in the device. It’s probably not going to do any significant harm but likely shortens the lifetime of the battery.

Hi Bateske - thanks for trying to help. I’ve actually tried a whole set of new 2016 batteries and none of them worked making me think it’s hardware related. I’ve test one of those batteries in a watch and it works so I know it’s not the battery.

Oh strange, it wont work with ANY batteries now?

But still works under USB power?

Very interesting. You don’t happen to have a variable output power supply that you could run some tests exactly what voltage it dies at?

To be totally honest, running these things on coin cell battery voltage is dramatically below specification. They shouldn’t be run lower than 5 volts and coin cells are nomanally 3v but really run between 2.7 to 2.5.

I’m no electrical engineer, but perhaps running for a long time at these lower voltages have over time damaged the gates in the controller so that they only function with the higher voltage.

Really curious on this is the first situation we have found. Did you run it for a lot of time on the coin cell? Where are you located? I’m wondering if maybe you could send it to me if you don’t have all the tools for testing.

Either way stay in touch we want to help you out any way we can! Thanks for letting us know!

Probably not. The ATmega32U4 is specified to operate properly at a minimum of 2.7V. Only running at higher than the specified absolute maximum voltage (6.0V) is likely to cause damage.

Even overclocking at 16MHz while running at a lower than specified voltage probably wouldn’t cause any physical damage. At most, it would just cause instabilities and crashes until a high enough voltage was restored.

Does the power switch control power only from the battery, or does it switch USB power as well? (Again, without schematics or my own DevKit, I can’t answer that myself.)

If it only switches the battery in and out, then the switch itself could be bad.

The switch currently doesn’t have any effect when the device is plugged into USB. I’m not sure if it used to reset the device originally (while plugged in), I can’t remember.

I’m still waiting on a multimeter, and then I’m also going to try and get hold of a variable power supply to try via USB to see when it turns on or drops out.

Thanks again for the help and suggestions guys.

If you want to test to see if the switch has broken:
With the USB not connected, and the switch off, and a fresh battery installed:
Use a wire or bent paper clip to short across the three combinations of switch contact pairs, one at a time

  • top to middle
  • middle to bottom
  • top to bottom

If one of those shorts causes it to turn on, then the switch is probably bad.

2 Likes

This is super helpful - i’ll try this afternoon!

SUCCESS! It seems the middle prong on the switch has a connection problem!

…and now it just works again! I was testing the paper clip to the middle prong again and when I removed the clip the arduboy stayed switched on. I gently switched it off, then on again and its working normally again! How could this resussitate the switch?

Thank you everyone for all the help - and especially Scott!

Two possibilities:

  • There’s a bad solder joint on one or more of the switch leads. Pushing down on the lead with the paper clip closed the break, regaining connectivity (perhaps temporarily).

  • The slider or some other part of of the mechanism within the switch became misaligned. Working the switch back and forth re-aligned the mechanism (again, perhaps temporarily).

Probably bad solder joint has broken finally. Do you have a soldering iron? If you quickly tap the iron to the leads of the switch, it should re-flow and make the connection again.

There is a small chance the actual pad on the circuit board has lifted off, and the solder won’t fix it. If you have this problem let me know maybe we can get you a replacement.

Awesome troubleshooting! Go Team Arduboy!

Thanks Kevin and Scott! If it stops working again, I’ll try the solder tap…

Note: If you are running an Arduboy library version greater than 0.1.0, and are using a dev kit, then you need to change the code in core.h.

I was experiencing blank screens on USB and nothing on battery until modifying core.h. Check the comments towards the top of the library.