SOLVED: My Arduboy has died while programming, I think it's bricked

I got my kickstarted edition Friday, and have been programming it this morning, and all of a sudden the device no longer appears under Tools -> Ports on my MacBookPro and the system no longer functions when powered up. It appears to be nearly bricked, other than the red LED comes on when attaching the USB cable, which goes out after a minute or 2.

How to I recover my Ardoboy? I was just about to test my sprite collision code!!!

thanks

B, storage and distributed systems hacker by day… game coding n00b by night

Hey Olmy,

Bummer about the issue.

Let’s try and troubleshoot this a bit if you are willing. My first thought is to try the unit on another machine with a couple different USB cables, if that’s possible.

If that isn’t possible, we can start trouble shooting the device through your computer.Please do see if you can connect it to another machine and see if anything happens. If so well great :smiley:.

As far as the Mac, try running:

system_profiler SPUSBDataType
# or
ioreg -p IOUSB

and pasting the results.

Here is the ‘ioreg -p IOUSB’ output from my mac. I have the arduboy switch to the right, which should be ‘on’.

Clearly it’s not even showing up at the moment :frowning:

bolen@207-181-230-92 ~ % ioreg -p IOUSB
+-o Root  <class IORegistryEntry, id 0x100000100, retain 14>
  +-o Root Hub Simulation Simulation@14000000  <class AppleUSBRootHubDevice, id 0x1000002f5, registered, matched, active, busy 0 (5 ms), retain 10>
    +-o BRCM20702 Hub@14300000  <class AppleUSBDevice, id 0x1000002f6, registered, matched, active, busy 0 (108 ms), retain 12>
    | +-o Bluetooth USB Host Controller@14330000  <class AppleUSBDevice, id 0x100000348, registered, matched, active, busy 0 (130 ms), retain 17>
    +-o Apple Internal Keyboard / Trackpad@14400000  <class AppleUSBDevice, id 0x100000306, registered, matched, active, busy 0 (498 ms), retain 22>
    +-o USB2.0 Hub             @14100000  <class AppleUSBDevice, id 0x100000d15, registered, matched, active, busy 0 (70 ms), retain 14>
    | +-o USB2.0 Hub             @14110000  <class AppleUSBDevice, id 0x100000d2f, registered, matched, active, busy 0 (63 ms), retain 12>
    | | +-o Fitbit Base Station@14114000  <class AppleUSBDevice, id 0x100000dae, registered, matched, active, busy 0 (115 ms), retain 21>
    | +-o Kinesis Keyboard Hub@14120000  <class AppleUSBDevice, id 0x100000d5a, registered, matched, active, busy 0 (86 ms), retain 12>
    | | +-o IOUSBHostDevice@14122000  <class AppleUSBDevice, id 0x100000dd2, registered, matched, active, busy 0 (96 ms), retain 13>
    | +-o IOUSBHostDevice@14130000  <class AppleUSBDevice, id 0x100000d93, registered, matched, active, busy 0 (58 ms), retain 11>
    +-o USB3.0 Hub             @14500000  <class AppleUSBDevice, id 0x100000d41, registered, matched, active, busy 0 (67 ms), retain 13>
      +-o USB3.0 Hub             @14510000  <class AppleUSBDevice, id 0x100000dfa, registered, matched, active, busy 0 (69 ms), retain 11>
      +-o IOUSBHostDevice@14530000  <class AppleUSBDevice, id 0x100000e11, registered, matched, active, busy 0 (59 ms), retain 11>

While I was doing some uploading before the board stopped responding, i was seeing some USB errors, such as the device wasn’t available, or timed out etc… I didn’t really pay it much mind at the time, just hit CMD-U again and it would work…

This is the same output with 2 different cables, i’ll try another mac shortly…

B

I tried a different mac (core 2 duo, MBAir, 10.7, ancient), no change, no sign on the USB bus of the Arduboy.

I got my Arduboy yesterday and mine appears to be bricked as well. Turning it on does nothing. Plugging it in while on brings up some led lights, red and green. If I upload a new sketch it flashes green and yellow, but nothing ever actually happens on the screen. :frowning:

Interesting update, I powered the device off while attached to the mac, powered it on, and the green LED left of the screen lit up and stayed on until i killed power.

Didn’t reoccur…

Whats the green LED?

B

orangeshoekid- what sketch are you uploading? Many are for the old version of the HW and will behave exactly as you describe on the new HW. I’d suggest trying the game that it presumably came with, blob attack. Your problem does not sound like the OP’s problem.

http://www.team-arg.org/blba-downloads.html

@olmy You should be able to recover the device using the reset button. I’m working on a guide with a video but here is the short version:

To recover an arduboy that won’t auto-reset and program, you’ll need to use the reset button. The reset button is located at the bottom of the device to the left of the usb connector. You’ll need a paperclip to activate it.

Prepare a known working software within the Arduino software, like hello world or some other example. Press the reset button on the arduboy and it will reset into bootloader mode, giving you about 6 seconds to press the upload button on Arduino. This is a little bit of an art because of the timing involved. You will want to compile the code once before pressing upload, because otherwise the delay of the code compiling will miss your reset window.

I’ll post up a guide with a video on how to do this to be more clear.

@orangeshoeskid Did the arduboy come this way or did this happen after trying to install new game? Try the rest procedure and see if that works out.

Yes you can’t be sure of anything until you do the reset - which runs the bootloader for 6-8 seconds. The problem is the USB is done partially in software on the Amtel32U4 so it’s possible for a badly behaved sketch to break the USB functionality completely - the way to restore it being to trigger a reset and run the known good bootloader code - which will allow a re-flash with a different sketch.

The example sketches included with the main library are good test sketches that should work on production hardware.

@olmy It happened after trying to install a new game. I’ve tried a few others posted on here and they don’t work, or only work for a few seconds and then stop. I went to the Team ARG site and downloaded Shadow Runner and it works fine.

We’ve started a list now of what is known to work:

http://community.arduboy.com/t/official-game-list-for-the-arduboy/783/3

1 Like

Thanks, I’ve been attempting this, but I haven’t seen any evidence that the reset button is doing anything, when I try and upload the IDE just lists the /dev/cu.Bluetooth-Incoming-Port device, which isn’t the one for the Arduboy… any hints?

@olmy make sure:

  • your Arduboy is ON (slider to the right) and leave it on ! (if the arduboy is not ON = upload not possible)
  • plug it into usb, using a CORRECT usb cable (meaning:it is not one only useable for charging, but can do data too, believe me there are a lot of cables only good for charging not for data, aka cheap usb phone charge cables)
  • press the reset button with a paperclip (at the bottom of the Arduboy)
  • a LED should start blinking (as long as it blinks, you can upload) Look for the blinking LED, let us know if it blinks !
  • upload a game known to work for Arduboy 1.0 (not for DEV) like for example Shadow Runner http://www.team-arg.org/ewExternalFiles/SHRUN-AB_v15.zip

PS: really …try an other USB cable AND see if the LED blinks when you hit reset (check both)

1 Like

The example sketches included with the Arduboy library are your best bet for something known to work. You don’t have to worry about obtaining or installing them.
Use File -> Examples -> Arduboy -> <sketch_name>

2 Likes

victory!

  • never discount the ‘check the cable’ because the second cable I had been trying was power only. (my only micro usb devices at hand were the Arduboy and a battery pack)
  • hitting the reset button didn’t give me any different lights, but if I hit it and immediately check the usb bus on my mac I did see the device appear.
  • futzed with the Arduino IDE long enough to get it to detect the board while in boot loader so i could select the device, and voila was able to flash my game back up there.

I’m back in business!

Thanks everyone,

B

2 Likes

@olmy GREAT !!!

Just one question … are you running Fusion or Parallels when trying to upload ? (if I do, I can’t upload)

PS: indeed checked myself , no LED’s change when you push reset !(only the red LED is on when charging)

no hypervisors are running at the moment… lets do a test…

firing up a docker-machine… (uses VirtualBox under the covers) doesn’t seem to have any impact on uploading from the mac native arduino IDE to the arduboy…

don’t have fusion on parallels, I always use virtual box when I need a vm…

B

Hey guys, my unit is also seemingly bricked with the same symptons described in the original post.
I only got to play with the new device for a few minutes and was just swapping games.

I press the reset button and I see two tiny lights flash once. Is it supposed to be continually blinking, and as bright as the Red LED? Because it definitely does not.

:frowning:

EDIT: To add some info.
The device shows up in my Device Manager when plugged in.
The Green progress bar will complete and disappear, but the Uploading comment stays.

Are you trying to upload an approved GOOD sketch?

Yes, I’ve been trying to reupload the Block game that came pre-installed on the unit.
Now I’ve been trying just the Hello World sketch.

I was able to switch games a couple times, but the third or fourth upload left it dark.

I tried hitting the pin, I saw the tiny dim lights flash once, and then quickly uploaded, but same issue.