[SOLVED]Need Help Please?


(Phil Graham) #61

Has a bit of a scare earlier attempting to load Chicken Cross, got this error below.

exit status 1
Error compiling for board Arduino Leonardo.

Checked everything was OK ran the sketch got the error, tried Box Stacker that loaded up fine,

Tried chicken Cross again same error, so went into the Chicken Cross game file only to see that the Box Stacker ino somehow got into the chicken Cross file.

Deleted the offending Box Stacker ino, re-run the sketch and Chicken Cross loaded on my Arduboy.


(Mike McRoberts) #62

Phil when you download games, how do you download them and what do you do with them after you have downloaded them?


(Phil Graham) #63

I download from github, put them into the downloads folder, extract them and edit if need be.

Then I move them to the Arduino folder.


(Scott) #64

@phil8715
Good! What you’re doing to install games now sounds correct.

If you can load a game into the IDE by selecting it from the menus using:
File then Sketchbook
then you’ve probably installed the game properly.


(Phil Graham) #65

It seems to work fine now.

Thank you for all your help :grinning:


(Phil Graham) #66

Just found a problem.

I tried to put a game on my Arduboy. The sketch worked fine on the computer, my arduboy rebooted but instead of the new game, it left on the previous game.


(anonymous30) #67

Sorted it. Did a reflash by pressing up button and power on.


(Mike McRoberts) #68

Yeah, I’ve had that happen a few times. I don’t know whether it is a quirk of the 32u4 chip or something to do with the Arduboy library.


(Phil Graham) #69

It could be the game Simple Flood Fill Puzzle which was the game that I had on when it wouldn’t flash, might be taking some of the bootloader.