[Solved] Need to check a library compiles on Arduino Due


(Pharap) #1

17 days ago someone complained that FixedPoints doesn’t work for Arduino Due, so I tried to fix it but they vanished before confirming whether the fix worked. (Exactly the same situation as last time.)

So basically I’m asking if anyone has a couple of minutes to spare and an Arduino Due they could use to check if a library compiles and an example runs alright.


(Scott) #2

I tried the FixedPointCalculations example sketch included with FixedPoints library V1.0.4 and it gives compile errors.

But you can try this yourself. In the IDE, install support for the Arduino Due:
Tools > Board: > Boards Manager
Install: Arduino SAM Boards (32-bits ARM Cortex-M3) by Arduino

Select:
Tools > Board: > Arduino Due (Programming Port)
or
Tools > Board: > Arduino Due (Native USB Port)

Select:
File > Examples > FixedPoints > FixedPointsCalculations

Try to compile it.

I don’t have a Due, so if you get a clean compile I won’t be able to test it. I do have a SparkFun SAMD21 Mini Breakout and a Rabid Prototypes Tau, which are both SAMD21 ARM Cortex-M0+ based. I get (the same?) compile errors with them but I can test them if you get a clean compile.


(Pharap) #3

It’s the master branch that needs testing, not the latest release.
I wouldn’t release a fix for an issue without getting some kind of confirmation that it works, that would be discourteous.

When creating the fix I installed the SAM boards and checked that it all compiles properly, but knowing it compiles isn’t the same as getting confirmation that it runs properly.
I’d be surprised if it didn’t run properly, but I like to make sure.

I’m not sure how similar Cortex-M0 is to Cortex-M3, but the environment should be similar since they’re both 32-bit and the libraries are presumably the same.
If I can’t find someone with a Due then that might be plan B, thanks for the offer.