[Solved] Nothing Downloads to my Arduboy

Hello, my name is Sam i am very confused about what this stuff means and i cant get anything to download to my arduboy, i followed the tutorials and tried all i could, i was trying to download Mystic Baloon’s but it is not working, if anyone can help please do. Thanks

Arduino: 1.8.5 (Windows 10), Board: "Arduino Leonardo"

C:\Users\name\AppData\Local\Temp\Rar$DIa0.870\MYBL_AB\MYBL_AB.ino:17:21: fatal error: globals.h: No such file or directory

 #include "globals.h"

                     ^

compilation terminated.

exit status 1
Error compiling for board Arduino Leonardo.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Have you followed the Adding Programs guide? It looks like the globals.h file is missing in the folder containing the sketch code.

How did you attempt to download it?

Usually for games stored on github you use the green “Clone or download” button, then “Download ZIP”, then right click on the .zip file and choose “Extract All…”, then follow the menu’s directions until you have a new folder, then find the .ino file in there.


(Sometimes you also have to rename a folder suffixed with -master to remove the suffix, but in the case of Mystic Balloon you won’t have to do that.)

Thanks man it worked

4 Likes