Some sketches side scrolling blurry display [Solved]

So just got it and am excited to play. Some games will load correctly while some do not. ArduSweeper and skateardDie works while Zuthsrah and adventuBoy does not. They will load but then the display scrolls from left to right and the images are all garbled…

Any idea if this is a programming issue or hardware?

If you have any questions please ask.


I had the same problem, try an older Version of the IDE or the library, fixen it for me


will try to find an older library and give it a test tonight after work

See this topic:

1 Like

I just found this post. Forgot I had made it…

Still having this problem. Just unintalled 1.8.4 and am trying 1.6.7

I already have arduboy 1.1.1 setup

it looks like the sketches aren’t actually taking to the arduboy. The light blips quickly then it goes back to the side scrolling arduventure screen


hold up button and turn arduboy on - go into flashlight mode (no screen flickering tho…)

then upload sketch from 1.6.7 and Boom!

working arduboy --(only took a couple years ;))


any way to mark the post at top Solved?
would be good for others to know!

Glad it worked out for you @Treflip! I’ve gone and edited the title. Thanks!