Sound missing when compiling Arduventure from source

I got a arduboy preloaded with Arduventure from the kickstarter. After playing the game, I loaded another game onto it (starduino), but then wanted to go back to Arduventure. So I went to the github repo and downloaded the source. I compiled it with the Arduino IDE (1.8.8), and loaded it without too much trouble (after realizing that I needed to do the reset trick to get it to load.) And it seems to work mostly, but the sound is missing. I’ve tried to turn the sound off and on again, and that hasn’t fixed it. My best guess is that the high score data from Starduino has corrupted the sound state stored in the eeprom data, but I have no way to test that. Anybody seen this?

1 Like

Do you have the latest ATMlib?

See:

https://github.com/TEAMarg/ATMlib/pull/18

2 Likes

That was it… I was using the latest that the library manager could find, but when I cloned the github repo and recompiled, then the sound was working fine. Thanks for the tip.

3 Likes

@JO3RI or anyother @TEAMarg members. Would it be possible to update the public ATMlib library sometime soon? the later Arduino IDE’s are being used more by the day and people run into this issue more often now.

3 Likes

@Mr.Blinky thanks for pointing this out. I created release v1.2.6 with your fix and it should be picked up soon by the Arduino Library, if not … let me know (might take a day, maybe 2)

3 Likes

Thanks for the update! will check in a few days.

1 Like

Library updates are usually picked up within an hour or so, as was this one.

It can take up to a week to modify or delete a given release, though.

1 Like

Im having the same no sound problem. Im using arduino 1.8.9, and i updated the ATMlib but no sound when i try the hex in projectABE. I also extracted the hex out of the .arduboy file and still no sound in projectABE. Im after the hex file for my flashcart.

I don’t think ProjectABE works with ATMlib?

So it might have sound on my arduboy then just not when I test it with the emulator?