Space Conqueror - Game Jam 3

ArduboyRecording

TO DOWNLOAD
LINK FOR SOURCE CODE:
Space Conqueror

NOTE: THIS GAME IS IMPLEMENTED WITH EMULATOR. I HIGHLY DO NOT RECOMMEND TRYING IT ON ARDUBOY. I have tried on 3 Arduboys when I was working on the game. After uploading on Arduboy, I could no longer upload any games. So I do not recommend anyone to upload my code on Arduboy.

This is my arduboy screen. I could no longer upload any games.

If you find out ways to fix it, please help me recover my arduboy. Thank you very much.

In Space Conqueror, the player will be controlling a space ship trying to attack enemies. At the same time, the player will have to dodge the enemy bullets. There will be 7 levels and each increasing level has more enemies.

Controls for the game
D pad - control the space ship movement
A button - attack/go to next level/ to reset depending on the mode
B button - available to reset the game only after the player wins over all the enemy and has gone through all 7 levels.

Thank you very much for playing the game. Any suggestion is highly appreciative. This is my first time in the game jam.

TO DOWNLOAD
Link to Git:
https://src-code.simons-rock.edu/git/awaiyanhein17/SpaceConqueror

Link to Hex: https://src-code.simons-rock.edu/git/awaiyanhein17/SpaceConqueror/raw/master/hex/build.hex

TO PLAY ONLINE
A link to emulator:
https://felipemanga.github.io/ProjectABE/?url=https://src-code.simons-rock.edu/git/awaiyanhein17/SpaceConqueror/raw/master/hex/build.hex

Enjoy playing.

4 Likes

Looks good but sounds dangerous …

1 Like

That link / source code is not publicly accessible.

1 Like

Can’t you change the game using flashlight mode (turn the arduboy off, press and hold up, turn it on)?
Also, the link is private.
Since you’re using the emulator, you can press P for a PNG screenshot or R to start/stop recording a GIF.

1 Like

Yeah there is some reflection in the photos.

I have changed the setting. Is it publicly accessible now?

yes it is. I can download the zip file now.

1 Like

Thanks for the recommendation. I have uploaded in GIF format as well.

I tried to use flashlight mode to upload the game on arduboy but it did not work.

I uploaded your build.hex to my diy devkit and I didn’t have any problems to upload a new sketch. After compiling your sketch I noticed 92% of ram is used and your sketch is probably suffered from the MAGIC KEY problem at the time you uploaded it to your arduboy. In that case flashlight mode won’t be of any help. you should press the tiny reset button left from the micro USB port.

Try

  • open a blank new sketch.
  • Press CTRL + R to compile
  • PRess CTRL +U to upload
  • press tiny reset button on Arduboy with a sim tool/tooth pick / paper clip

Edit:
If you’re using the latest Arduboy2 library. Try holding down the down button while switching on Arduboy and keep the down button pressed continiously and try uploading a sketch

1 Like

No. As long as you don’t overflow RAM, causing it to never get to the call to flashlight() then flashlight mode should work.

The Down button is only tested if the USB stack has been removed using ARDUBOY_NO_USB.

That’s a link to a new project (or the one that’s stored in your browser). To share it with others, you need to host your code somewhere then replace “new” with the url. Like this:
https://felipemanga.github.io/ProjectABE?url=https://your-url-here
I suggest putting both the source and a hex file on github.com.

To upload new games, do this:
While holding the UP button, turn on your arduboy.
The screen should now be white and the LED should be shining.
Now try uploading any game

I have brought Arduboys back to life using flashlight mode many times, and a few times I have also been able to get them back using the reset button.

In this case the flashlight mode does not seem to work. The sketch will say that it is uploading in the Arduino IDE, and the Arduboy itself will reboot during the upload process as normal, but in reality the new sketch is not loaded and the previous sketch starts again.

I tried the reset switch approach a few times to no avail, but in previous cases I’ve had to try the reset switch many times before finding success. So it is possible that the three Arduboys can be brought back using this approach.

1 Like

More information: @Lancelot had emailed me the version of the game that was causing the Arduboys to be bricked and it was only using 1887 bytes (73%) of dynamic memory. Furthermore, almost all of the variables that would contribute to RAM usage were statically allocated in the global scope. In other words, it is unlikely that the RAM usage changed much during the normal course of entering and exiting functions.

(After the Arduboys started getting bricked, @Lancelot switched to the emulator and eventually started using 90+% of the dynamic memory, but again this was after the bricking.)

I’m not sure if this additional info helps, but if you have any other thoughts on bringing these Arduboys back up, then that would be great. Thank you!

1 Like

When using the reset method are you using something small like hello world or another game? I find I have better luck using the library examples rather than larger sketches.

If all fails you can flash them with a hardware programmer Bring your Arduboy back from the dead (burn bootloader)

2 Likes

I will definitely be investing in one of those hardware programmers! Thanks for the tip!

1 Like

Unless the arduboys are unlocked, it doesn’t sound like you need a hardware programmer. If the bootloader was damaged, the arduboy doesn’t show up on the computer at all. :confused:

You could try using my erase sketch python script. It auto detects Arduino port and erases page 0 of the application/sketch area so the bootloader will remain in bootloader mode forever.

After succesful erase, it won’t be a problem selecting the right com port in Arduino IDE and there won’t be a timeout when compiling/uploading takes long.

  • Press reset button on Arduboy
  • count to three
  • double click erase-sketch.py

Note Python 2.7 + PySerial needs to be installed.

2 Likes

Thanks all, I’ll follow up on this when our semester is over (which is soon!).

You can now find a copy of the .hex file (and an online ProjectABE emulator link) for this game on the Game Jam 3 polling page: [POLL] Game Jam 3 Vote!