Square Nose - the Squarrel

Tournament based on time to finish the three levels
(minutes, seconds, tenths of seconds)

Categories:

  • Square Nose or Lethal Mouse
  • loop: 0, 1 or 2

Why do you say it’s difficult? I removed the time over :laughing:

I love the game, but I think my max is 6. lol! Shame on me.

Lets go for the Tournament!

I compiled the newest version into a hex but when i run it in projectABE theres no sound. Not sure what i did wrong. Otherwise the game plays fine (and is tough as nails lol)

Thank to Square Nose, Arduboy will be in Japan Expo, Paris, this july.
https://www.japan-expo-paris.com/fr/exposants/2019/square-nose-color_10719.htm

4 Likes

Last painting I made from Square Nose characters. RGB style. Hand made with brush. Clear picture and blur picture. Acrylic on paper, 65 x 50 cm, 2019.

4 Likes

New painting, Arduboy style. 65 x 50 cm, acrylic on paper. Japan Expo in two days.

1 Like

Arduboy was in Japan Expo (Paris, France). Four days of fun with Square Nose the squarrel. A lot of people tried the game and discovered the open source game devices (Arduboy, Gamebuino Meta, Pokitto and Kitco).

7 Likes

After a very long time, I am working again on coding Square Nose. Maybe not on Arduboy, but there will be a 4th level with a boss. It will catch the targets instead of you, and you will have to avoid him to win. Here is a video from the unfinished version. I will have to slow down the opponent to let the player being able to dodge it.
Ultra Square Nose (320x256)

5 Likes

Hello, here is a new video from my game “Square Nose Color” (with the updates). I have a YouTube channel now, so take a look at it! https://youtu.be/rmoecIFblBU

2 Likes

I am happy to receive my three Ardugirls… I mean, three Arduboys FX today, after ordering them “recently” two years ago. My games are on it (exept “Cutie E” that is too much cool for non educated eyes).
I found a bug that I have never seen before: “Square Nose” has many of its sprites not displaying correctly. It miss the bottom parts. I don’t know if their are other bugs in the other games. I will try them soon.


Does anybody else has the same strange display? I have the “Arduboy FX Pre-Mod, Handmade, 236 Games CRC: 22474E09”. If nobody has the same bug, could we say that I own super rare edition that I could sell a hundred times the normal price?

1 Like

Uh oh, the games are modified slightly. The hex have been patched to include the holding up and down to reset. It’s possible this messed up something in your code, sorry I didn’t catch it!

@mr.blinky any ideas?

Are games being patched ‘automagically’? Some of my games already have code to return to the bootloader by holding the down button when on the title screen. This was done to compensate for the lack of USB support.

Youd have to ask the blinkmiester for details, but I think it repurposes timer0 to add a interrupt that looks at the button state. As I remember it, his code retains the origonal function, and still takes up less memory space.

It checks to see that the timer0 function has not already been changed, so it checks that it matches the original, and then replaces it with his own.

So if you’ve got your own functions to reset the device, it will retain that.

OK … so if its doing it at that level it should be fine.

I wonder why it affected @JuiceLizard’s games then?

I checked, it isn’t the patcher.

Unfortunately somehow the hex file that was provided to me has this glitch for some reason:

https://felipemanga.github.io/ProjectABE/?url=https://bateske.github.io/ArduFXTest/Platformer/SquareNose.hex

This is before the patch was applied.

Not sure how that would have happened, I see it’s running fine at the top post here.

Who gave you the .hex/how did you acquire it?

If it was compiled by someone who uses a clone or has cause to have Mr Blinky’s clone package installed then it’s possible they compiled it for a system with a different screen, which might account for the bug.

Or if it’s a really old .hex it might still have that old Sprites glitch where the inline assembly was misbehaving.

@mameise put together the origonal collection.

I guess he probably compiled it himself?

Sorry…

I think @mameise used a homemade Arduboy.
If it used a non-standard screen that could explain things.

AFAIK most of the original hex files where grabbed from the Game’s topic and not recompiled. Some games that used EEPROM 0 or had another issue where recompiled. But can’t rememer Square Nose was one of them. Maybe it was an old version?

A post was merged into an existing topic: The Curse of AstaroK [V1.0 With Sound]