Stuck in a scrolling text loop [Solved]

I just got my Arduboy today and was trying to upload the example scripts. When I did it started making everything scroll. Nothing I do has fixed it. I’ve reset it, put it in safe mode and uploaded, different computer, different cable, everything. It uploads new scripts just fine, but they all scroll by and are unlplayable. Thank you for any help. There is a video at the bottom of what’s happening.

1 Like

@bateske, @MLXXXp, you guys think this might be a bootloader problem?

@corystanley, have you tried putting the mode into flashlight mode to fix the issue?

1 Like

@crait I have tried that. I have tried that along with resetting at the same time. Nothing has fixed it.

I had the same problem, fixen it by using older IDE and library versions


Thanks man! It worked! I’ve been pulling my hair out for 3 hours trying to figure this out and your fix worked!


Which Versions did you use? (I want to figure out what’s the latest working version)


I used IDE 1.6.7 and library version 1.0.0.

1 Like

Did it work when you received the unit? This is pretty strange! If it only happened after upload then it must be software, have you tried using the hex uploader that @crait made?

It did work when I first got it. I tried to upload the music script in library 1.0.1 using IDE 1.6.12 and that’s when it happened. I tried to then put Arduventure on it and it was doing what you saw in the video. After dropping back to 1.6.7 it uploaded Arduventure perfectly.

I have not tried using the hex uploader.

Alright looks like something probably got updated in 1.6.12

We had some stuff get broken in the graphics library before by arduino updating their SPI core libraries, so perhaps this is happening again. We will look into it!

I tracked the problem down to be either 1.6.11 or 1.6.12 since 1.6.10 seems to work fine.

1 Like

@ekem get this man a medal he is doing good work :smiley: Thanks!


Did you mean Arduboy library 1.1.1 (not 1.0.1)? You need to use 1.1.1 with IDE 1.6.10 or higher to prevent the screen corruption problem.

Could you try IDE 1.6.12 with Arduboy library 1.1.1 again. If you still have the problem please select from the IDE menu:
File > Preferences
and set Show verbose output during: compilation

Compile the sketch using verify or upload and make sure that the output confirms that you are using Arduboy library 1.1.1 with the line:

Using library Arduboy at version 1.1.1 in folder:

Another thing you can try is loading a Team A.R.G. game. These games use their own custom library which should not experience the problem. This will help determine if it’s actually a problem with the newer IDE versions.

Personally, I haven’t had any problems with Arduboy library 1.1.1 (or any Team A.R.G. games either) under IDE 1.6.12

Moderator Note:
Links to Team ARG’s website have been removed due to malicious new owners.


I did mean 1.1.1. I didn’t type it correctly.

I tried it again using 1.6.12 IDE with library 1.1.1 and it worked perfectly. So I don’t know what happened when I went to do it the first time.


I’ve been having the same problem…
I have been using the latest update of 1.6.12 IDE, but version 1.0.0 for the Library…I’m guessing the issue is the library - but i have no idea how to update it to a version that will work.

If you installed the Arduboy library according to Step 2 in the Quick Start Guide, you should be able to select
Sketch > Include Library > Manage Libraries...
then in the Library Manager "Filter your search..." field enter:
Click on the Arduboy entry.
You should be able to update to the latest library (currently 1.1.1).


oh, thanks - yeah that did it. I thought I had been doing that the whole time, but I guess I must have missed one or two steps along the way…

thanks again. :smiley:


I am using arduino 1.8.4 with arduboy 1.1.1 and can’t get out of the looping menu. tried ARG team game too…

holy crap. I fixed it!

So watching the video gave me the idea to put into flashlight mode

Then I uploaded a sketch from arduino 1.6.7 BOOM!

got it to work :wink: