The Curse of AstaroK [V1.0 With Sound]

Still my most played arduboy game atm

4 Likes

Really glad you enjoy it.

1 Like

hi hi, i’m trying to compile this game using @Mr.Blinky homemade-package, with an sh1106 oled
and i’m getting this error, i have no idea what is it or what it’s doing it, would really love some help

https://pastebin.com/JfkSDhZv

EDIT: i used VLQP, arduventure, midnight wild and omega horizon, and they work just fine, the only error i’m having is with this one

I am not one 100% sure but in this game I have removed the USB support to save space. In the game though, you can press the down button while on the main menu to exit to the bootloader. With the homemade-package, this functionality may not be supported or is replaced with a method in the bootloader itself.

If you comment out this line 39 here > https://github.com/Press-Play-On-Tape/The-Curse-Of-AstaroK/blob/7dfcb6ce17a0f6e727b8d4754412257ebfe4ebcf/Curse/Curse_TitleScreenState.ino#L39 < does it then compile?

1 Like

I’ve compiled The Curse without problems. Try uninstalling and reinstalling the Homemade board package.

1 Like

Ah good to know. I would have been surprised if my guess was the real issue.

1 Like

Oops! I have to redact that as I had the Arduboy2 library installed for a test. To solve the compile problem you have two options:

  • Remove Curse\src\utils\wiring.c and wiring_private.h in the same folder (Preferred)
  • Select standard Arduino core from the Tools menu (Easiest)

The Arduboy optimized core contains an optimized wiring and adds the ‘UP+DOWN for 2 seconds reset’ feature.

1 Like

After a lot of trying last night around 4am i made it work like this but wasn’t sure if it was the same as the optimized core

This worked just fine! Really thanks for the help n.n)/

(this is my fav game haha)

2 Likes

So good to hear that! Thanks

3 Likes

I received my FX today, woohoo!

I have noticed that all my games are fine (there are so many other games to check I focussed on mine first). I did notice that ‘The Curse of Astarok’ doesn’t reset when using in the game itself by pressing up / down together whereas other games do, Not a big issue - turn the device off and on to go back to the loader; press up / down from the game’s main menu; or press down alone from the game’s menu (this is the original code I put in).

I am more curious as to whether it wasn’t patched or whether my music is getting in the way of the patching?

1 Like

Does your game make use of timer0? If the timer0 function is defined in your code, the patcher wont touch it.

I will say no as I do not even know what timer0 is!

The FX is fantastic by the way - everyone should buy one or two!

1 Like

Consult the @Mr.Blinky

What sound library are you using, it probably is the culprit as it might modify timer0.

ArduboyTones.

But I just looked again, it is using Mr.Blink’s wiring.c library that does stuff. Not sure what but I see timer0 in there!

We’ve reached the end of my knowledge, gotta wait for the floating bodyless ghost to wander past.

1 Like

It’s because the game uses one of my custom wiring variants and could not be patched. I PMed you a while ago before/during the FX Gold Cart was worked on with a request to update it.

Ouch … and did I respond and forgot about it or was I just rude and ignored you. Sorry :persevere: I must have missed this or forgotten about it.

You didn’t respond. I thought you might be too busy then over time I also forgot reaching out once more.

Maybe you get a 2nd change with the Production Arduboy FX. Unless @bateske already submitted the flash image?

There were like 4 months where the entire flash image was up on github, the time for changes is past.

1 Like

This is a really great game. Great concept and fantastic game play.
I was looking for some kind of adventure game and really glad I found this.

1 Like