Tiny Asteroids - Zero gravity

will you release “tiny asteroids” & “tiny 2048” for the arduboy, too ???


actually, my all games maked 1.0 version before few days.

pls see github :slight_smile:


maybe i am just too dumb but i have tried everything to get your games working. may you or someone can help me?? :cry: :cry: :cry: :cry: :cry:

i have changed “test.bat” to the following:

@echo off
SET VAL1="C:\Program Files (x86)\Arduino\hardware\tools\avr\bin"
SET VAL3="C:\Program Files (x86)\Arduino\hardware\tools\avr\etc\avrdude.conf"
SET VAL5=test_arduboy_10.hex

set PATH=%VAL1%;%PATH%

tool\reset %VAL2%
avrdude -C%VAL3% -v -patmega32u4 -cavr109 -P%VAL4% -b57600 -D -Uflash:w:%VAL5%:i


i have changed all the BOLD above. the path and the com ports as this is my IDE install path and COM 9 is my arduboy. all sketches working fine to upload them with the arduino IDE.
then i was looking for your “make_bin.bat” ; “make_clean.bat” and “make_usb.bat” and fixed the pathes there, too.
compiling your game ends up as the following output in the dos box:


avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
Copyright © 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright © 2007-2009 Joerg Wunsch

     System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr\etc\avrdude.conf"

     Using Port                    : COM8
     Using Programmer              : avr109
     Overriding Baud Rate          : 57600
     AVR Part                      : ATmega32U4
     Chip Erase delay              : 9000 us
     PAGEL                         : PD7
     BS2                           : PA0
     RESET disposition             : dedicated
     RETRY pulse                   : SCK
     serial program mode           : yes
     parallel program mode         : yes
     Timeout                       : 200
     StabDelay                     : 100
     CmdexeDelay                   : 25
     SyncLoops                     : 32
     ByteDelay                     : 0
     PollIndex                     : 3
     PollValue                     : 0x53
     Memory Detail                 :

                              Block Poll               Page                       Polled
       Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
       ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
       eeprom        65    20     4    0 no       1024    4      0  9000  9000 0x00 0x00
       flash         65     6   128    0 yes     32768  128    256  4500  4500 0x00 0x00
       lfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       hfuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       efuse          0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       lock           0     0     0    0 no          1    0      0  9000  9000 0x00 0x00
       calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
       signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

     Programmer Type : butterfly
     Description     : Atmel AppNote AVR109 Boot Loader

Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding
Drücken Sie eine beliebige Taste . . .

test.bat is equal the log of Arduino IDE.
your editting is correct.

i think my reset.exe is wrong.
new bug… i saw that for the first time.
but modification idea is nothing…

umm… reset.exe reset the Arduboy into bootloader mode.
if you physically do, page will be helpful.

new test.bat here. i added only “rem”.

@echo off
SET VAL1="C:\Program Files (x86)\Arduino\hardware\tools\avr\bin"
SET VAL3="C:\Program Files (x86)\Arduino\hardware\tools\avr\etc\avrdude.conf"
SET VAL5=test_arduboy_10.hex

set PATH=%VAL1%;%PATH%

rem tool\reset %VAL2%
avrdude -C%VAL3% -v -patmega32u4 -cavr109 -P%VAL4% -b57600 -D -Uflash:w:%VAL5%:i


how to use.

  1. physical reset.
  2. wait 1, 2 sec. timing will be important.
  3. execute new bat.

if no good 5 times, please give up.
i tested only devkit. i dont have arduboy 1.0.

i bricked my arduboy many times and i am an expert now in resetting it and bring him back to life :blush: BUT no chance to to get the game uploaded to the arduboy :cry:
is there anyone else who got this to work on his arduboy and if yes - how ???

1 Like

Here goes nothing.


1 Like

well, i tried everything including changing all COM constellations but i have no luck or i am just an idiot. i don’t get your games to work on the retail arduboy. no chance and i also used the “fixed” makefile from @cactus described at Tiny 2048. I fixed this file myself yesterday already and had no luck.
@bateske PLEASE send @akkera102 his arduboy NOW !!! i need his games :joy: :joy: :joy: :joy: :joy: :joy: :joy: :joy:


When will it run on Arduboy 1.0???

(sorry about my english)

as soon as @akkera102 holds his retail (factory) arduboy in his hands. just be patient a little bit :wink:

1 Like

normal of windows computer can play game with arduboy 1.0.
dogfriend computer is rare case… probably…:sweat:

really? it dosen’t work to compile on my win 10, win 8.1, win 7 and also no chance with my mac…
and all are different hardware :hushed:
all other games work to compile with the notebooks above :wink:

1 Like

i will check out at a friends’ pc, okay? maybe i am just to lame to setup the os correct :grinning:

1 Like

your all machines is Failure?
to be honest, i dont know where the problem.

if any people say failure, i will delete support infomation.

none of my notebooks will compile it for the arduboy 1.0 to work.
if you say it works on arduboy 1.0 then people shall post here that it works on arduboy 1.0 with pic or vid !! and let me know how they got it to work :wink:

@cactus, Would you help me?
i hope to Arduboy 1.0 can play game.

1 Like

How must I edit test.sh if I have mi arduboy connected to /dev/ttyACM0???

export avrdudeconf=/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf 
export uart=/dev/tty.usbmodem1421 
export hexfile=test_arduboy_10.hex 
python -c "import serial;ser=serial.Serial('/dev/tty.usbmodem1421',1200);ser.write('');ser.close()" 
sleep 2 
avrdude -C${avrdudeconf} -v -patmega32u4 -cavr109 -P${uart} -b57600 -D -Uflash:w:${hexfile}:i

Edit by @ekem to use Markdown code blocks.


export avrdudeconf=/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf
export uart=/dev/ttyACM0
export hexfile=test_arduboy_10.hex

python -c "import serial;ser=serial.Serial('/dev/ttyACM0',1200);ser.write('');ser.close()"
sleep 2
avrdude -C${avrdudeconf} -v -patmega32u4 -cavr109 -P${uart} -b57600 -D -Uflash:w:${hexfile}:i

and… osx must have python + pyserial.

Thank you very much for your reply.

I dont use osx, I use linux. Must I have python + pyserial?

1 Like

yes. linux must have python + pyserial too.

1 Like

aaaaahhhh man, what a pitty. i don’t get it to work on my arduboy 1.0. anyone else with an arduboy 1.0 who has luck and running this MUST-HAVE-GAME ??? @RamonML - did you got it to work on your arduboy 1.0 ???
i reaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaally need these nifty little games from @akkera102