Tiny Asteroids - Zero gravity

thank you advice.

gamebuino often change game.
it change hex file.
probably if it is changing hex file when it turn off, it broke.

I feel flash time is tooo long.
but I plan to use it carefully.


My Arduboy turned up today. I’m really happy :slight_smile: Although I need to finish an assignment, this is a distraction I don’t need (but I do want!).
I did get the game to install. It’s awesome ! Thanks.

My Arduboy shows up as COM8, so that’s VAL2, and I used COM9 as VAL4 and it uploaded. Try adjusting the VAL4 com port to be one above your Arduboy com port and see if that helps when running the bat.


Any word on whether this will be fixed for use with production models?

Tonight I going to try using a MacBook.
Any recomendation???

I was able to install Python and Crosspack but I can’t install Pyserial and save Test.sh as Unix Unicode.
Failed mission :worried:

This game is why I supported the Arduboy KICKSTARTER. I hope I get to play it on my Arduboy some day…

You can play.
Dowload “test.hex” file from Github repository, import in @crait Download Manager and tranfer on Arduboy.
Work on my retail Arduboy.


I want to play Tiny NS Tower but it’s also like that.

Thank you best answer! I’m glad :slight_smile:

My Github repository puted hex flie for Arduboy 1.0.
pls use Download Manager.

My development use CLI(gcc-avr, avrdude.exe, makefile).
so, Arduino IDE can not used.
I like old Technique.:sweat_smile:

1 Like

I can’t find the .hex file!

go to
Tiny NS Tower github

you will see a green button at top right corner labelled “clone or download”

click on it and choose “download ZIP”

download to your computer and extract the .zip file

within the extracted folder you will see


import that to your Arduboy manager and transfer

(I would still prefer all games with source files to learn code, and upload via the IDE)

1 Like

Sorry my bad, I did see test.hex but I was expecting it to be called TinyTower.hex

1 Like

lovely job. Works fine thank you @akkera102

1 Like

Where did you get make.exe 1.0.6? Also I assume you are developing under Windows based on the batch files but not if sure also using cygwin or something like that also? Also great job on this clone. Just got the Aruboy and this really takes me back 30 years when doing 8 bit controller dev.

make.exe is here.


Windows ZIP file for non admin install




C:\Program Files\Arduino\hardware\tools\avr\bin

if your computer is 32bit, you can compile.
pls execute make_bin.bat. my development don’t use cygwin.

but if your computer is 64bit, you must change bat and makeflie.
Arduino IDE of install default folder is “C:\Program Files (x86)”.


change it in three places.

1 Like

I have installed make and updated the makefile to match my Windoes 64bit system.

I first tried running the make-bin.bat but it failed so I tried running “make” from the src folder and I am getting the following error:


assembling core/wiring_pulse.S

The system cannot find the path specified.
make[1]: *** [obj/wiring_pulse.S.o] Error 1
make: *** [all] Error 2

I am assuming the environmental variable to find the “#include <avr/io.h>” is not set but I am not sure which variable name the avr-gcc is expecting or something like that. Any idea?

umm… I want more infomation.

cd src


mkdir obj

"C:/Program Files (x86)/Arduino/hardware/tools/avr/bin/"avr-gcc -c -g -x assembler-with-cpp -mmcu=atmega32u4 -DF_CPU=16000000L -DARDUINO=10606 -DARDUINO_AVR_LEONARDO -DARDUINO_ARCH_AVR -DUSB_VID=0x2341 -DUSB_PID=0x8036 -DUSB_MANUFACTURER=“Unknown” -DUSB_PRODUCT=“Arduino Leonardo” -Icore/ core/wiring_pulse.S -o obj/wiring_pulse.S.o

dir obj

do you see wiring_pulse.S.o?
or please log.

Thanks I figured it out after running the command you suggested above. I had installed Arduino in an alternate location and the makefile didn’t like that. I can build it now using make and Arduino 1.8.2.

1 Like

I’m glad the problem was solved :slight_smile:

If someone wants to make this work for the current version of Arduboy on Arduino I would be very grateful :wink:

1 Like