Trouble uploading HEX [Solved]

Will see, what i can do later, have a lot of work to do.
If i can’t upload only one game, it’s not that big a problem…

I feel guilty as its my game you are having all the trouble with … but in my defense, I know others are not having the same problem so I assume its hardware or software related and not my game.

You even asked me before uploading it whether it disabled USB (which it does not) and I said ‘everything will be OK’ … and its not!

Sorry, Nicole!

2 Likes

Ah, i don’t feel it’s a big problem, i can play lit‘s of games without problems. Don’t worry.
:roll_eyes: Can’t upload a video, format not supported.
And i don’t have the time to convert it…
I am running windows 10 btw

Image too big?! Nothing is going to work today…

So i try to describe what’s going on:
Team arg uploader:
Either flashing normally, but nothing happens and program says flashed successfully.
while flashing blinking yellow two times on left and staying red on right), or blinking a few times yellow only, not showing orange as far as i can tell this fast. Or flashing completely with yellow and orange lights and giving me the error message avrdude.exe ERROR no valid record found in intel hex file „t - rest truncated on screen.
Arduboy Manager:
Click transfer, flashing yellow and orange, telling me Transfer to the arduboy at COM5 complete! but nothing happens - same on both arduboys, driver installed again, pc shut down, boot up new, tried to put arduboy in after and before opening both programs.
Don’t have more time though now, have a lot of work today.
But, really it’s not that big problem for me…

1 Like

I am not sure I understand. What game did you flash onto your arduboy? Was it ‘Dark and Under’ V2.0.2 or something else? Either way, it appears to have worked (or am I missing something?)

I did try a lot of other games, the problem only occurs with turtle bridge, can‘t upload the crucial pics somehow…

So … help me out here.

You can flash other games to the device but you cannot flash Turtle Bridge?

1 Like

Exactly.
I just compared the difference:
While flashing other games all three light on the bottom horizontal bar are blinking, with turtle bridge red stays the same, doesn’t show at all or only yellow and orange are blinking. The top left vertical led indicators are showing nothing.
But very sorry guys, have to go now…
Missing appointments otherwise

1 Like

Ok, I wrote a test for you to do, and I decided to eat my own dogfood before sending it and I’m having problems getting it to work with basic avrdude commands. It seems similar to the other problem people have been having with arduino and “butterfly_recv(): programmer is not responding”.

I’m tracking it down here:

I have a second PC, same problem, but no fresh install, oh man, i gotta hurry up, getting my shit done today :laughing:

I just want to make sure I am understanding the problem. You have multiple Arduboys, trying to flash from different pc, and everything works except for just the turtle hex file?

Image because, this is crazy:

Is this image correct for you? The games just mean you can switch between something. Doesn’t matter which one. Any other game…

2 Likes

Yes, that’s it. I did try the hello world sketch and a lot of different games (including the mentioned ones)

Sorry I didn’t read this earlier:

image

I’m pretty sure you’ve saved the HTML data of the github page to the hex file, which is what that links to. Because doing so will cause the exact error you’ve got. I just tested it to be the case.

The best thing to do is just left click on the download button of the emulator window. OR you can save that link if you want. But the other link is to a github webpage, not actually the hex file.

The reason I suspect this enough to meme it is I’ve done the same thing on a number of different occasions.

3 Likes

:open_mouth: That’s weird, because it has the correct extension and after saving the file from the embedded link i did not get any sound at first - will try this again as i have some time later, would be very funny if that’s what happened

Yeah it still saves as a hex file, that’s why it’s tricky. I ran into this problem a lot when I was seeding the community with the embedded emulator at the top of the post. I’d save someones link with right click, and not know why it wasn’t working.

I’m very nearly certain this is the problem. It’s the only way it could be the issue.

1 Like

Yes! That was the problem! Thank you guys. Never thought that THIS would be the reason :laughing:

2 Likes

Let’s hope our game was worth the trouble :wink:

3 Likes

Of course - as all of your games are fantastic and i love game and watch games😉
Was my fault, but i just didn’t expect this.

1 Like

Ah, I was misunderstanding the problem earlier.
I thought you couldn’t upload anything else after uploading Turtle Bridge.
I didn’t realise it was the other way around. :P

1 Like