Trouble uploading sketches!


(Cody) #1

Please help I can’t upload sketches!


(Holmes) #2

Cody, if you want people to help you, you need to make sure that they know everything they can about the problem that you are having. Saying that you have a problem is not enough.


(Cody) #3

I have checked every connection I can find!


(Holmes) #4

Cody, that does not help anyone understand the issue that you’re having. In order for us to help you, you’re probably going to have to answer most of these questions…

  • What kind of computer do you use?
  • What program are you using to upload sketches?
  • Which version of the program are you using?
  • Does your computer recognize that your Arduboy is connected?
  • Have you tried using another cable?
  • Is the Arduboy on when connecting it to your computer?
  • Have you tried installing the drivers for the Arduboy?
  • Which sketch are you trying to install?
  • Have you tried using another sketch?

(Cody) #5

Toshiba windows
Arduino 1.6.13
No
Yes
No
Yes
Hello world
No


(Holmes) #6

Hmm… It sounds like to me that your problem is not that you cannot upload sketches. Your problem is that your PC is not recognizing your Arduboy.

You said you did not have your Arduboy on? Your Arduboy needs to be on when connected to the PC.

That should allow your PC to detect the Arduboy. A way to check if it is detected or not is to use the Windows Device Manager.

To open the Windows Device Manager program, click the Start button, find the Control Panel, click System and Security, and then, under System, click Device Manager.‌

When the Device Manager program opens, you can click the Ports section to see what things are connected to your PC.

There should be a Arduino Leonardo there. If there’s not, let me know!


(Cody) #7

Yeah it did but a yellow triangle with a ! Mark appeared :disappointed:


(Holmes) #8

Which COM number is next to it?

This may be an indication that you need to re-install the drivers. Try using the following thread: Arduboy Driver Installation [Windows & OS X]

If that solves the problem, make a post in this thread to let me know!


Can not connect Arduboy [Solved]