Unable to upload file to community [solved]

I just tried uploading a hex file (and also a zip file) to the forum. But after it’s uploaded an Upload error is reported and the file is not added to the post.

Anyone having same issue?


Edit: It seems to fail in Firefox. Chorme works fine.

It would seem not:

Minesweeper.EN-GB.hex (59.5 KB)

(I am on Firefox.)

Worked fine for me. Firefox under Ubuntu Linux.

HelloWorld.hex (17.8 KB)

Does it work after restarting the browser? Perhaps clearing the cache?

Thanks @Pharap @MLXXXp for testing.

Yep I tried that and some other things before I made the post. Odd thing is I tried today the same on my Windows laptop @ work using Firefox (latest version) and get the same error.

Any chance you’ve got like an ad-blocking router or something like that?

Might be one for the discourse forum but so far it seems to be an isolated incident?

Solved my problem.

I have the clearURLs addon installed that even caused problem when filtering was disabled. A workaround is to disable the add-on from the add-on list for an upload and re-enable it afterwards.

It’s still odd though as the problem only occurs on the Arduboy community and not other similar discord communities.

2 Likes

I’m hosted on discord so I wonder if it’s their host that’s doing it, other people might have their own deployments.

I don’t know if the google api maybe the other sites aren’t using it?

Looks like the difference is that Arduboy community uses AWS/Uppi/Javascript which uses ETag headers and the other site used plain old html post method.

I’m betting it’s hosted on Discourse, not Discord.

1 Like

Sold bet.

My guess is yeah they are probably deploying it on their own server which uses this method, and it’s free to do so. I’m paying a monthly hosting fee.