Unable to Upload game

Hi there,

Its been a while since I’ve used my Arduboy and wanted to change games on it. Every time I do, I’m always so hesitant to do it, its so frustrating every time. I was able to change games on this before.

I’m now trying to change games from the ones I have saved in my MacBook Pro. I’m getting the following errors below (screenshots). I’ve never had this one before, usually have port com issues. Any suggestions. I click OK to make them go away and brings me to the Arduino application. I just tried to upload the simple “HellowWorld” program, went to Sketch - Manager Libraries - Library Manager - then it pops up the same errors re: Ignoring library with bad name. Clicked OK to make them go away. Checked all software required based on list from Arduboy website installed. Latest versions. I go to Tools - Board and find Arduino Leonardo, then Tools - Port….and this is where I’m lost. I’m unable to find the correct Port. Below (screenshot) of what my options are. When I select anyone, I get an error on the Arduino app and no game gets uploaded on my Arduboy. I’ve noticed unplugging and plugging in of my Arduboy from my Mac doesn’t react to it. No beep or sound that indicates its connected. I keep getting errors on the Arduino app. (Screenshot below).

Please help.

Thank you kindly.

To fix the problem with the bad library name I’d suggest deleting “ATMlib 2” and “ATMlib 3” in your library folder.

Looking at your system config, it looks like you’re going through a USB-C port. Are you using a hub or a single dongle to connect to the Arduboy? Some USB-C hubs on mac have shown to have some problems and potentially be incompatible. If you’ve mentioned it working before my suggestion is try to replicate the connection of cables the same way as you did before.

Also, which cable are you using to connect to the Arduboy? Have you confirmed it works to send data (i.e. can use it with other devices) and not a charge only cable?

1 Like

I am using a Mac on Big Sur and can upload with no issues. I am connecting via a normal USB - not via USB C.

What game is on the device at the moment? It is interesting that you cannot see the device in the ports list. As Kevin suggested, watch out for USB hubs. If this doesn’t resolve the problem, press the reset button and see if the port appears in the list then.

1 Like

Okay. I changed the usb cable. I am using an usb c adapter to normal usb and I’ve changed the usb that goes into the arduboy. It made a difference. Now its a matter of settings. Am I doing it right?

You’re right, its the cable. I’ve replaced it. I am using a usb c adapter, from my Mac I have the adapter connecting to a usb mini. Now its the settings. What programmer do I use?

1 Like

I’m still getting the error pertaining to programmer did not respond?

Try AVRISP mkII. That’s what mine’s set to and I can confirm it works.

(I believe ArduinoISP is for burning bootloaders rather than uploading games.)


After double-checking, it appears the programmer doesn’t actually make a difference.

In which case I’d advise double-checking the cable is in properly and isn’t moved during upload.
If you have the option, I’d suggest trying a USB A connection instead of using a USB C adapter.

You don’t need to set the programmer drop down, that’s only for burning the bootloader. It can be set for anything during the upload phase.

Are you trying to flash a game or burn a bootloader?

To upload the game you click on the image button.

You need an external programmer soldered to the bare PCB to burn the bootloader, I don’t think that’s what you are wanting to do.

If you are getting the error during upload, click the “copy error messages” button and paste it into here.

I’m trying to upload a game that I’ve uploaded before but its been a year ago. I have some games I’ve downloaded onto my Mac.
Here’s the error: Arduino: 1.8.13 (Mac OS X), Board: “Arduino Leonardo”

Sketch uses 26100 bytes (91%) of program storage space. Maximum is 28672 bytes.
Global variables use 1735 bytes (67%) of dynamic memory, leaving 825 bytes for local variables. Maximum is 2560 bytes.

avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
Found programmer: Id = “”; type =
Software Version = .; Hardware Version = .
avrdude: butterfly_recv(): programmer is not responding
avrdude: butterfly_recv(): programmer is not responding
avrdude: error: buffered memory access not supported. Maybe it isn’t
a butterfly/AVR109 but a AVR910 device?
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

avrdude: butterfly_recv(): programmer is not responding
avrdude: error: programmer did not respond to command: leave prog mode
avrdude: butterfly_recv(): programmer is not responding
avrdude: error: programmer did not respond to command: exit bootloader
avrdude: error: programmer did not respond to command: exit bootloader

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

What game is currently on the Arduboy? Is it Arduventure by any chance? Oh wait it shows up in the port so maybe not Arduventure.

Some games need a special sequence to be able to upload again.

Trolly Fish. Just tired of it.

One of the games I’m trying to upload is called Sirene. I keep getting errors as shown.

As you can see, I’ve resolved the cable issue. Its reacting now whenever I click the upload button, lights start flashing, before it didn’t. Also this is my settings on Arduino.

Unfortunately this seems like a bug that effects OSX and the leonardo, and I haven’t seen any good specific fix for it.

If you haven’t already it might be worth restarting the machine and trying again.

I know in unbuntu there was some conflict with modemmanager but I’m not sure how to attack that from the OSX side, or even if that’s the real issue.

You might try the methods in this video:

Trollyfish has the flashlight mode, so if you hold down the up button while you turn the device it will put it into a kind of recovery mode. Try to upload then.

If it still doesn’t work you can press the reset button and then attempt the upload as well. When you press the reset button the Arduboy is in the bootloader for about 3 seconds and you can try the upload then.

If you have any access to a PC then you might try from there I’m pretty sure this is related to OSX unfortunately.

OMG!!! It worked, I put it on flashlight mode and clicked the upload button on the Sirene Master game. I’ve got it on my Arduboy now. Thank you, you guys are the best!!!

2 Likes

Is the problem with Trolly Fish? I’m now able to freely upload other games, I’m afraid to upload the Trolly Fish.

It’s kind of complicated to say, but basically some games run in such a way that they don’t like to be reset. They need to be reset in order to be reprogrammed.

Using flashlight mode prevents the game from running, from doing the thing that prevents it from being reset. So that’s what’s nice about flashlight mode is it makes it easier for it to be recovered.

If you are interested in the more complicated reason it’s because the system needs to have a bit in RAM set while the device resets for it to enter the bootloader. If the game somehow changes the value set it RAM before it resets, then the bootloader won’t run. The flashlight mode keeps the system in a tight loop, that doesn’t effect the system RAM, enabling a safer environment to be rebooted.

1 Like

After being able to change different games, I stopped at this BlackJack game and I’m unable to upload any further. I think its the cable issue. I am using the usb-c adapter to usb mini. I’m now not able to see it in. my port like before. Any suggestions?

There is a solution, on these games where the port doesn’t show up, you need to hold the DOWN button while turning on the device.

There is a general guide to trying to get things to work:

There are some games that the developers decided to remove the code for the USB port to appear as a serial port while the game is running. @filmote and @vampirics made the “Press Play on Tape” games and almost all of them do this. Which is probably the source of much frustration to many users after they buy the Arduboy and become frustrated with it. Thankfully you take the time to write in and ask questions but I think most people just give up and never look at it again. I’ve asked developers to clearly indicate on their game if this is the case but it’s up to them to implement this or not.

I think the problem lies that most developers are so used to doing these steps they forget that it’s not published anywhere easy for people to get to. I guess I’ll have to put the reset dance on the front page in a very obvious place in a troubleshooting guide.

Okay, so I’ve noticed, I have to keep holding down the DOWN button and upload the Sirene game. Other games won’t let me. Am I stuck with this game. I was able to switch easily before? This has been a new MacBook and transferred my Arduino files with it. Can anyone provide me link to other games “user-friendly” similar to Sirene? Please?
Thank you.