Undertale Maker

Hello everyone today im releasing an alpha AKA early access version of my game Undertale Maker. please do keep in mind that this is a alpha and still has more work to come thanks.

ALPHA 1

Moved it into the demos section, when you’ve got it all done feel free to move it down a level. Keep it up!

1 Like

Hey @Cody17,

I downloaded this but cannot get it to compile. The ‘main’ file (where are the file extensions), seems to have two separate programs within it - there are two setups, two loops and so forth. The first looks incomplete, the second refers to enemies.h and enemieslist.h which do not exist.

I think the commit went haywire!

1 Like

Ummmm. Sorry I will fix that today must have uploaded a corrupted file sorry.

1 Like

Look forward to seeing it!

1 Like

Just fixed it but for some reason you have to copy and paste the raw code. Sorry everyone :disappointed:

Its interesting that the .ino and .h file extensions have been stripped off. How are you adding them to GitHub - are you doing it via the web interface, command line or the desktop app?

I’m clicking and dragging into the web page

Is this still a thing or has it past?

No it’s pretty much gone but anyone can try there own version. But if I had help I would continue.

Can you post up the code.

1 Like

It’s in the first post, it’s just missing the .ino extension:

The computer I had this on is toast!

Why is there no .ino and how do I get the game.

As @Pharap pointed out, the main should be called main.ino.

Get it from here > https://github.com/cody17/Undertale-Maker

1 Like

There is no game.
It was never finished, it was just a demo of an idea @Cody17 had.

You’d have to take the code from github (which @filmote just linked to), manually add the .ino suffix to main and the .h suffix to Bitmaps and then compile in the Arduino IDE.

Were are the .h files

There are 4 files in the repo.

  • .gitignore
  • Bitmaps
  • LICENSE
  • main

Bitmaps and main are code, LICENSE is the licence, .gitignore is unimportant.
Neither Bitmaps or main have the right file suffix.
Either @Cody17 will have to add the suffixes on his repo or you will have to manually add the suffixes when you download.

Bitmaps is supposed to be Bitmaps.h - you have you add the .h suffix yourself.
main is supposed to be main.ino - you have you add the .ino suffix yourself.

You said @curly? Do you mean @cody?

Oops. Yep. Fixed it.
(I saw a ‘c’ and a ‘y’ and my brain filled in the rest, incorrectly.)

3 Likes