Upload with Arduino IDE works but not with Arduboy Uploader

First: Sorry, I feel like this problem must be in this forum thousand times or more, but if I search for it, I don’t find something identical.

Upload with Arduino IDE to my Arduboy works, but not with

  • Arduboy Uploader
  • TeamARG Game Loader
  • avrdude

So I’m not able to upload hex files to my Arduboy. I really want to try out Erwin’s Arduboy Collection.

What I tried:

  • different PCs: 2x Win7, 1x WinXP, 1x Linux
  • installing Arduino IDE (for driver support) and Arduboy Driver Installation [Windows & OS X]
  • push reset switch on Arduboy and set it to flashlight mode
  • start uploading within the first 8 seconds after powering on my Arduboy

On every pc Arduboy was listet as “Arduino leonardo” without warnings as a regular serial device in the hardware devices list.

Any idea what’s wrong with me, my systems or my Arduboy? Is the bootloader wrong? As far as I know I never did something to my arduboy since buying it in Nov 2018. I just put a few games on it that were available as arduino project.

Thank you very much!

What game is currently installed? It may be a hint as to what is happening.

You could try holding UP while powering the Arduboy, or hit the reset button (next to the micro usb port) while the animation on the Uploader is looking for your device

@sjm4306: Currently MicroCity is installed. But before I had other games installed with Arduino IDE and the same problems with Arduboy Uploader and the other tools. Whole list of games that were installed on my arduboy:

@eried: I tried both, like I posted already, but that didn’t work.

Kind of odd that avrdude doesn’t work and Arduino IDE does (it also uses avrdude) The one difference I see between the uploaders and the Arduino IDE is that the Arduino IDE has a longer retry period / connect timeout. Which makes me wonder if you’re USB cable is wonky. Have you tried another USB cable and/or different USB port?

the correct procedure should be:

  • Turn on Arduboy while pressing up to enter flashlight mode
  • start uploading within the 8 seconds after reseting Arduboy

It’s possible that avrdude actually is working.
From experience I can say that getting the reset timing right for avrdude is a pain in the neck.