[WIP] Arduboy Dock - 3d printed dock + RPi

Ok when i get you Right:

The fix is already included in your GitHub, so if i downloaded from there i have the fix.

Then i assume the issue is still there as the repo is in arduboy/repo :frowning:

Edit: It also seems it can find the repo Directory but only parts not…
So i wonder what else should be there beside the games. Are there mandatory Folders or files to be added?

only games, directly from the repo. Can you post a video of the structure showing the screen and what you are doing?

I think you are manually typing it :rofl: so maybe you are in the wrong path or something like that

Yes i am manually typing it as i have no idea how else i could get it here :slight_smile:

Well the repo folder contains all the Folders of the categories and within the Folders of the games and within the games itself. I also already tried flashing a game with the other script and that worked, so the games look ok.

I type:

mono uploader.exe &

and Always get the unhandled exception “Could not find a part of the path ‘/repo’”

I am worried i cannot make a Video of it :frowning:

Ok i think i got a picture now :slight_smile: See the folders and the folder they are in on the top.

And here is now the error:

Nice, could you copy that repo to the root? I think the person who changed that messed it up now

It should work with that. Just copy /home/pi/arduboy/repo/ to /repo (in the same level as /home)

Wohoooo wow thank you that indeed worked :slight_smile: :slight_smile:
had to copy with sudo but at least now it started.
When i install the


from the PC and then connect it to the dock i can browse and install a game. just wonder how i now can get back to the uploader.

When i connect the arduboy i get an error if a game is still installed:

Great! I will revert the change then, to fix it.

You need to unplug and replug it, but some games require different procedures as explained here: The Reset Dance: How to fix your Arduboy no matter what (this is with normal uploader too, not only for the dock), basically unplug the arduboy, then plug it again and hold up or hold down or push the reset button (if nothing works). Most of the old games should not require anything special.

Ok thank you very much. Seems this tricks are dependent on the game used so i assume
something different on my side. The game i have on it i can easily Flash another having the
arduboy plugged in normaly with another uploader. But as you said: WIP and to be honest
i use the USB port with an USB-OTG Hub and do not have the capacitor or the resistor soldered
in between. So i will order These parts (as i do not have exactly matching ones) and try further.

Thanks again for your help and your work, Looks already really promissing :slight_smile:


What i am just wondering now: Do i have to place the “uploader.ino.leonardo.hex” somewhere?
Or any other file? Because how should the uploader be able to Flash it without having it? Or does it have it included in the .exe?

I have deleted all files from the GitHub except the .exe as Nothing else is mentioned and it works at least to Flash a new game. But as all attempts to reflash the uploader fail i was wondering if that could be the issue :slight_smile:

uploader something.hex file needs to be next to the .exe file in that same path. I guess there was a lot of missing pieces of information :nerd_face:

Hmm did that without Change. I now also hooked up the Micro USB port as mentioned.
I had a 16V 220uF capacitor, i think that should do the Job. I do not have a resistor smaller than 10Ohm so i left it out.

Works to get the list of games, also works to Flash a game but when i unplug and replug to Flash back the uploader i still get the Errors.


It resets the Arduino but Fails flashing back the uploader because “not responding to ping” - could it be the timeout is set too short or something like this? I am no programmer at all so i am just thinking of what could be the issue without knowing if my thinking are legit so please forgive me if it makes so sense :slight_smile:

If you flash a game via my website, does it work normally? http://arduboy.ried.cl ? Put a game that you know it is easy to reflash and try again

What do you mean, not sure :slight_smile:

Of Course flashing in General works. Also with your uploader it works:

I Flash the uploader.ino.leonardo.hex from my PC to the arduboy and plug in the arduboy to the RPi and the arduboy recognizes the dock and loads the list of games.

Now i can Flash a game without Problems. But if i want to load back again the uploader by Pluging in the arduboy again to the RPi it does not work just keeps resetting.

When i then plug in the arduboy to my PC and use your loader to load back the uploader.ino.leonardo.hex it also works and i can plug in back the arduboy to the RPi to load another game.

I use Farkle as it seems to be easily to Flash and reflash etc as no tricks are needed and arduboy is recognized directly.

So not sure what i should try on your Website and also to sure if i should try on RPi as there i am just connecting via ssh and would not know how to open a Website via ssh :slight_smile:

Edit: just tried flashing a game from your Website on my PC with the link “Flash on my arduboy” and yes, this also works.

The RPi or the arduboy? What the log is saying? can you send a snapshot. With what you say it should already work

The arduboy keeps resetting.

Where can i find logs?

See, there is a new error: Protocol error

Yes, for some reason the serial is not staying open. I would say it is something electric in the usb, sadly the ports in the raspberry pi are dependant a lot on your power supply, and specially if you have the zero you need those caps. Which Pi are you using?

Let me test something and I will post a small update as a release so it is easy to test.

I cannot find my arduboys :sob:

1 Like

Thanks to the endless effort and Patience of @eried i was now able to also set it up successful. The Problem seems to be somewhere in the newer Image. I had to use the Image from 2017 and then it worked without any issue.

Thanks again, this is really a perfect solution for me as the arduboy can stay untouched and i still have a headless solution on the go. I have also built a Version with a lipo included so it is really mobile. I am reworking it at the Moment but i can share files if someone wants to also build it. I have hooked the Micro USB port plus and minus directly to the lipo charger so when the dock is turned off it Acts as a power bank for the arduboy. If turned on it is the Genius dock with full functionality as intended :slight_smile:


awesome! post it as a derivate in thingiverse

1 Like

Have finished the reworked version. Will post it on Thingiverse later.


Fancy :grin: why is that lip in front so big? to really grab the arduboy?

Well the main reason is that i wanted to have the Micro USB covered when i carry it around. And yes, it gives good stability and i even feel save to keep it attached while gaming (turned off as powerbank)

1 Like