[WIP] Arduventure (RPG)


#41

I’m not exactly sure what causes this issue, but I’ve experienced it when I used too much memory with global variables and also when I used PROGMEM wrong.


#42

Thank you so much!!! :smiley: I’ll do my best to release a playable version soon!

@Roo & @fuopy: I installed a new version of the Arduino IDE and it seems to have fixed my problem. I think it had to do with a known issue of some kind of bootloader variable that is stored somewhere around 2kb in the RAM so when you reach that amount of RAM usage it can be overwritten with other data and that’s why it went wrong. It should be fixed now hopefully so development can continue :slight_smile:


(Kevin) #43

When I make a dev kit for version 1.1 with an SD card you’ll be the first person to get one :smile: Keep up the good work!!


#44

Hehe thanks a lot :slight_smile: That would be awesome!!! Knowing that eventually the Arduboy will have an SD card reader I decided to not make my game too simplistic. That’s why I added the ability to choose your own name, display item descriptions, and a bunch of other details that aren’t completely necessary and would save memory if removed but I’m doing it anyway cause it just makes the game feel like a proper RPG.


(Shane Gibbens) #45

Due this is awesome, your beating the rest of us to the punch. When you complete this, hit me up and i’ll make you a custom 3D printable case, as programming a game like this was gonna be my next task. A adventure game in the style of Pokémon/Zelda, with battles, rewards, progress growth, and character building, you can’t beat that.

:smiley:

P.S. If you need help with Sprites Creation let me know and I’m happy to land a hand.


#46

Thanks a lot :smiley: I sure will, thanks in advance :slight_smile:
Would be cool to make a game like Zelda with realtime battles! I challenge you to do that! :wink:

Thanks for the offer but I’m fine on my own.

I do want to note that development might slow down a bit as the bootloader glitch I talked about earlier didn’t get fixed with the new Arduino IDE… I’m just an artist with some programming knowledge and don’t know much (/anything) about arduboy/arduino hardware so I leave fixing the issue up to those who do know ^^’

I also went back to a previous project that I abandoned a little bit since I started working on Arduventure (Tales of Lena, a retro styled platform game for PC).


(Gavin Atkin) #47

Have you tried creating a hardware boot into ‘safe mode’ so that even if the sketch gets broken and you cannot upload, you can hold a button combination to allow reflashing?

Batesk has tutorial on how to reflash the arduboy when it stops allowing reflashing floating around the forum somewhere so once you implement the safe mode code you will be able to flash it that way.

Edit: should just be a matter of check for the button combination at startup and forcing an idle loop when it is pressed. That should allow reflashing at that point.

Hope that helps.


#48

Yeah I know there you can hold UP and LEFT while powering on the Arduboy to go into safe mode but it doesn’t work to upload something new on it… Only the shorting pads reset works! How to Reset the Dev Kit


(John) #49

It´s look like amazing!
I can´t wait to play it.
Good work!


#50

Kind of late reply but thanks anyway :smile:

Haven’t really worked on Arduventure lately, been doing some other things like working on my main game project and now doing some digital painting :wink: I hope to work on it some more again next week!


(Kevin) #51

Would love to have this game available even just as a demo for the launch of the kickstarter units! :smile:


#52

I should be able to have a playable/finished version by then :slight_smile: For now I’ll just work around the reset problem, it won’t be an issue anymore for the kickstarter units (right?)


(Brian) #53

Version 1.6.7 of the Arduino IDE is out, might help…


#54

I don’t think it’ll fix the problem as it is related to the bootloader… But I’ll check it out when I get home just to be sure :wink:

EDIT: No change…


#55

This looks boss! i wanted to write a text based adventure for the Arudboy but this blows that away! Good work


#56

Thanks :smile:

Finally working some more on the game! You can sleep in the bed to restore all your health and now I’m working on the shop. Talking to the shopkeeper(s) already triggers the item menu, which looks exactly like your inventory except obviously it only shows specific items the shop has and its price instead of amount.


#57

New video showing off buying and selling in the shop and saving your progress! :smile:


(Josh Goebel) #58

See the other topics on “safe mode”, etc… once your sketch gets over a certain size you are just stuck with this behavior until we fix the bootloader.


(Josh Goebel) #59

It should work to re-upload, that was the entire point of the feature.


#60

Those posts are kind of old now and in the meantime I already know what’s causing the problem :wink:

I decided to just keep working on it and do the shorting pads reset every time I wanted to test my game. Strangely enough I’m now at 1,975 bytes of RAM and the glitch doesn’t occur anymore!