[WIP] Arduventure (RPG)


(Carlos) #162

Thanks. I’m already familiarized with arduino and knew the procedure. Tried by myself before posting here a couple of times without luck. Tried again after reading you and worked fine :stuck_out_tongue:


(Mathias Della Tonia) #163

Hello,
I just got my Arduboy a few days ago and I have not been able to install any game after Arduventure. I tried everything that was suggested, what should I do?


(Gavin Atkin) #164

There is a reset button near the usb port on the Arduboy. It’s a timing thing, I don’t remember the exact timing, but try pressing upload, waiting a moment then pressing the reset button on the Arduboy before the upload (on a different sketch) has finished. If that doesn’t work after a few tries, try pressing the reset button then upload. I think it’s the first way though if I’m remembering correctly.


(Mathias Della Tonia) #166

Thank you for the suggestion, I tried both ways, about 10 times each and still did not go through.
Thank you though!


(Scott) #167

Holding the UP button while powering up should enter flashlight mode. The RGB LED to the left of the display should light up white. Is this happening for you? If so, you should then be able to upload a new sketch.
http://community.arduboy.com/t/arduboy-gets-a-life-conways-game-of-life/578/10


(Mathias Della Tonia) #168

Thank you so much, that worked perfectly!


(Cody) #169

Please make a sequel I loved it


(Kevin) #170

Trying to figure out what is causing the units to lock up… We had this problem before where Arduventure took up too much ram and overwrites an address in RAM that is used to indicate a software reset.

But now we are using the latest bootloader on the Arduboy which moves the position in ram way out to the end, so this shouldn’t occur.

I’m pretty sure I remember testing this, is it possible these are being compiled with older versions of arduino?

@MLXXXp any suggestions? are you able to test this?


(Kevin) #171

Hello @karman and @MathiasTonia can you please tell us what version of Arduino you were running?

It looks like it’s an issue with Arduino 1.6.12 (possibly earlier, works just fine in 1.6.7, checking others…) and above broke something for us.

The flashlight mode will work to get it back, but you will need to close all instances of Arduino. Unplug and turn off the Arduboy and wait for the COM port to disappear. Then you can hold the up button while turning on the power, this will turn on the RGB led to full white indicating it’s ready to be programmed.

For beginners it’s not recommended to install this right now and if you do run into this issue check this thread and post your issues here:
http://community.arduboy.com/t/cant-upload-sketches-after-arduventure


(Gwenael) #172

Hi everyone,

I’m new here and I really want to try this game !
Still not a good idea to download it ?
I can’t wait xD.


(Gavin Atkin) #173

@Generu This demo I think will still work with the updated Arduboy library and Arduino IDE 1.6.7 it looks like. It can just make it difficult to flash your unit. You might need to put it into flashlight mode to flash a new game.


(Jun-Liang Tan) #174

Can’t wait for this to be completed! :grinning:


(Anthony K C Chong) #175

any new progress on the game? seems like no updates in months


#176

Yep lots of progress, but we are keeping it off the radar :smiley:


(Gavin Atkin) #177

I’m hoping we can get a new teaser out soon!


#178

Yes me too, but @DSSiege11 needs to finish the banner and title screen :laughing: :laughing: :laughing:


(Nick Eel) #179

This game looks awesome! Any updates on the development progress though? Nothing has been updated in almost a month. A full version of this game would be amazing.


(Kevin) #180

It’s coming, when it comes out, you won’t miss it! We are going to try and plan some special launch for it, maybe even do something really special… uh… :wink:


(Nick Eel) #181

I can’t wait :smiley:


#182

Yeah, we’re working on this, but we took it of the grid until finished.

it should have:

  • a map bigger than the one of Zelda’s “link’s awakening”
  • 4 different worlds
  • multiple chiptune songs

Can’t spoil it all can we now :wink: